Inkscape 1.0 rounded corner path effect

Has anyone figured out how to use that live path effect to get rounded cuts? I used it to round my shape, but it does something strange where it adds the rounded fillets/chamfers but it’s not actually modifying the path.

I’ve tried converting the object to a path, thinking maybe that would add nodes. No dice. I tried adding nodes to the path as usual, thinking that might force it to change to a real path… no luck there either.

I’ll keep prodding it, this is annoying. The old plugin I liked for rounding corners is no longer working with Inkscape 1.0.

Is this what you’re looking to do…


For a more complicated shape. I can do corner radii on rectangles, those convert to nodes and true paths when you do object to path.

In this case, the GF UI does not recognize the fillets in Inkscape’s svgs. If I can’t figure this out I will open a support ticket to request that they start to support it – this is now a native Inkscape feature and it will come up again.

1 Like

Oh boy did I just figure out a dirty hack to solve this.

I drew a small shape on top of the existing shape, selected both and did Path->union. The larger outer chamfered shape absorbed the smaller shape and the entire thing was converted to a true path. Now I have real nodes instead of fillet/chamfer handles. That’s nasty because it’s destructive, but at least it worked.


Can you show a pic of what you did?

Like this…



Original shape. Hard corners.

Go here, and then add a fillet/chamfer.

I chose a 1cm radius and fillet.

Draw a small circle inside your larger shape… Note the weird green “nodes” on the main black path, those at fillet/chamfer handles, not nodes. The node is still there on the corner, floating in space.

Select both, and do a Path->union. Now it’s a true path and the circle was gobbled up.


1 Like

Well there you go. I couldn’t understand what it was you were trying to do.

I use Inkscape exclusively. Honestly, have never needed to do fillets but to investigate I just tried it. After performing a fillet operation the fillet path effect is shown in the layer. If I select the object and perform a combine the path effect disappears from the list but the nodes do not change. I’m guessing it could be uploaded to the GF at this point since the path effect is gone. Haven’t tried it yet.

I found several effects like that which only enclosed the original but did not change it. Object to path did not change them. Fortunately, most were of little interest to our context and there was not much incentive to find one,

One like that was pattern fill and a trip through Gimp allowed it to become vectors. Perhaps that might work for you.

Yup, a combine (Control-K) would probably work too… I suspect any boolean operation will. The path effect gets lost, that’s what I meant by it being a destructive process. Ideally glowforge would support the inkscape fillets and we wouldn’t have to lock them in as real paths first.

I think they do. The chamfer handles convert to nodes and it’s a plain path. You lose your original corner node.

Strange, when I do the convert to path after applying the camphor effect it seems to work the way you want it to on may machine. Have you tried moving the project onto a fresh document? Any hidden groups or other path effects that it might be interacting with?

After seleting object to path/ version

opens correctly on the dashboard as well.

Hmm I’ll try it again but this was the most basic situation possible, fresh document, no groups, etc.

Hope it works out, there is that “clean up document” thing under file at the top. Doubt it will change anything but might do something if you press it, i use it to remove hidden clips and blank text that flags up an error on the machine.

That removes blank text? Hah my solution was totally janky by comparison.

I’d create a new text object, then select same object type and delete them all. Heh your way is better.

If you do object to path on this does it work or same problem?
File is object from above just before the object to path command. (2.0 KB)

First thing I tried.

Thought that maybe a file saved on my pc might work on yours but it was a long shot. Was thinking it might help find the issue if it worked on the file i sent vs one saved on your machine but odds are both will be messed up.

Playing with this It would seem that Stroke to path might be what you are looking for.

1 Like

Nope. I don’t want to alter my dimensions. I suppose I could get janky with it and stroke to oath a filler shape, then pull out the resulting filled inside shape but really the boolean trick works fine.

Also it should be noted that the radius setting is broken. It’s a known bug and apparently fixed in the dev branch release. As of now though the radius is in a unit that I’m not aware of. Maybe pts? In any case it’s definitely not cm when I clearly set it that way.

1 Like