Inkscape 1.2 version not opening older version files

On a second computer having no Inkscape installed, I installed the 1.2 version. When I try to open a version 1.0 file, Inkscape 1.2 won’t open the file. Wants me to revert to Inkscape 1.0.
I had many Inkscape crashes using the 1.0 version trying to get LPE fillet to work, so was hoping to use 1.2

Anyone know how to open old version Inkscape SVG’s in version 1.2?
PS I can have trouble with ANYTHING!

What did google say? No luck?

Hmm google didn’t have much.

Tell us exactly what steps you’re taking and what happens.

What have you already tried to do to fix it?

If you provide a svg that won’t work, maybe someone with 1.2 can confirm whether or not they have the same issue. It would help to narrow down whether it’s inkscape in general or something specific about your install.

What operating system are you using?

What version specifically are you using? 1.2, sure but what are the build numbers?

1 Like

I have it working, I think. I clicked on the svg file expecting it to launch Inkscape 1.2 and got asked did I want to install 1.0. NO! Eventually I used Open or Import from a running 1.2. This worked on the few files presented for choice.
Most of the svgs (old versions Inkscape) were in another directory, so changing directory made them available.
I Imported into 1.2 a previously 1.0 crashed saved svg made trying to get LPE to make fillets on the design. LPE fillets in 1.2 version worked perfectly. And to get rid of the knots (shown in green instead of regular nodes) and turn them into nodes, all you need is to Path → Object to Path. In 1.0 I had to use your workaround,

Glowforge palette was available as was the 20 X 12 inch size window. Now to get the dark theme changed.

2 Likes

Operating system is Windows 10.
The download file was labeled: inkscape-1.2_2022-05-15_dc2aedaf03-x64_FKau6eX.exe

Don’t know if you can do it on Windows, but I kept the 0.92 version of Inkscape on my Mac as various of revisions 1.x were released until I was happy with one - the early releases were horrible. Just right-click on the file and select the version to open it with. I also kept prior versions of 1.x around until I was satisfied with the next release. No limit on how many versions you can have.

Well I loaded 1.2 and it opens the oldest files (and more recent ones) just fine with a regular double-click on the file. This is on Mac, so it sounds like a bug in the Windows version.

Install recommendations for Windows was to uninstall previous versions first. If you put the install in a separate folder, then apparently you can have separate versions on same Windows computer. I just used the uninstall first, then default install for version 1.2

I wonder if anyone has tried to install the extensive collection of Extensions mightyscape made for Inkscape 1.0 in the 1.2 version?

2 Likes

Bingo. The install for 1.2 didn’t update the path for the app associated with svg files. Easy to fix in the OS - right click on an svg in the file explorer, click “open with…”, select the new version, making sure to select “use for all files.” (Or words to that effect…)

2 Likes

My basic problem is not knowing what to do: I chose to download the *.exe rather than the *.msi for Windows. Bad choice. The *.msi route fixed the problems.
I did try to use the “open with” but couldn’t find the location and app name for Inkscape as I had installed it. Eventually figured it out, then uninstalled the *.exe download and re-installed with the *.msi version.

5 Likes

I have had issues with 1.2 accepting any of the old extensions, but I haven’t spent a lot of time on it.