Inkscape Factoring in kerf when importing SVG to Glowforge?

I’m trying to make some very precise acrylic rings 3" in outer diameter and 2.55" inner diameter. The ones I made in Glowforge are spot on without messing with figuring out the kerf for this. The Inkscape circles are one unit but I can see what the outer diameter is and it’s 2.995"

I would just make these in Glowforge but there isn’t an auto center two elements in the Glowforge software is there?

Any ideas what is happening here? Is it stroke or line diameter related in Inkscape?

I’m sorry this isn’t quite clear to me.

Glowforge does not auto kerf correct if that is your question.

As for aligning, inkscape has a great suite of alignment and arranging tools.

You should understand the difference between bounding box options in Inkscape, look in your preferences for “visual” versus “geometric” bounding boxes.

As for aligning in the UI, you can do it with a little work in the precision placement to get things aligned with simple shapes like circles.

If this doesn’t answer your question, maybe a rephrasing would help us help you figure it out.

If I create a 3" diameter circle in Inkscape, it opens in the GF UI at precisely 3".

The path definition in the source SVG file defines the radius as 38.1 mm, which is exactly 1.5".

The GFUI has no concept of style and stroke, and ignores those parameters. There is no “kerf correction”.

It seems like it’s more of an Inkscape issue vs a Glowforge import/convert issue?

Just made this test SVG in Inkscape, 3" circle, converted to path.

Inkscape Circle

After importing into Glowforge the dims changed. I know I can probably change the dims in Glowforge to a flat 3" but I’d like to remedy this instead.

Upload the source file.

Centering objects in the GFUI is actually quite simple.

In the screen shot the x and y give you the coordinates of the center of the circle. The circle has a diameter of 2.732 inch. If you create another circle, say 2.532 inches and change the x and y coordinates to match the first one, they are centered. Now its merely a function of selecting them both and placing in your desired location.

1 Like

Like I said, I bet you’re in visual mode. Go into your preferences and be sure you’re in geometric mode or you’ll fight this forever.

If you’re already in geometric mode then something is up. As it stands now I think you just haven’t fooled with that setting.


Found the setting, testing now.

circle test

One thing I noticed was when I made the initial circle it asks for a W and H and I put 1.5" and 1.5" it generates a 3.006" diameter circle. Changing that to a flat 3" imports it smaller into Glowforge, however keeping it at 3.006" imports it into Glowforge at a flat 3". I’ve been changing that and getting smaller circles. The SVG has both circles in the file.

A workaround seems to be to let Inkscape do it’s thing but it’s frustrating not understanding how or why.


It’s in behavior.

If I’m right, you are using a stroke of 0.006 inches, which is why it’s presenting as 3.006.

That’s what the visual bounding box means, it’s the size of the visual presentation of your shape, not the actual geometry of your shape.

Found it, it was right in front of me.

Seems to be working now and I can make an actual 3" circle in Inkscape and have it import exactly at 3".

Thanks everyone for your help.

It’s a really common issue with people who are new to inkscape, it catches almost everybody. If you find yourself with the time, go through all of the tutorials you can find because there are lots of other hidden gems.


This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.