Inkscape Not Working on Latest MacOS...?


#1

Have upgraded my Mac to 10.14 Mojave and now Inkscape appears to not be working. Anyone else have this problem? I appear to have the latest version of Inkscape installed…going to check my xQuartz next.


#2

Try re-installing xQuartz and InkScape. Sounds like something got hoarked permission wise in the upgrade process.

I’m running Mojave and Inkscape/xQuartz run as well as they every do.


#3

I have lost the use of to many software applications during the OS update process, forcing me to rebuy them. Now I always put the updated OS on an external drive, so I can boot in the old and new operating systems.

It is good to hear that Inkscape can run on Mojave!!! @bbum


#4

Huh. I just upgraded to Mojave, and got this when I tried to start Inkscape from the menu bar:

But when I double-clicked on an SVG file, XQuartx loaded, and then after thinking about it for a while, it loaded Inkscape and opened the file. So it seems to still work, you just maybe can’t get into it in all the same ways.


#5

That means that the version of Inkscape you have is built for 32 bit only. At some point in the future, Mac OS X will stop supporting 32 bit applications.

Looking at the Inkscape official download page, it looks like Inkscape should be built 64 bit these days. Are you running an old version?

https://inkscape.org/en/download/mac-os/


#6

Dunno, I’ll have to look and see–thanks for giving me the link so I can be lazy! :slight_smile: I’ve been mostly using Affinity Designer lately, but there are still a few things I resort to Inkscape for. Node editing doesn’t ever work like I expect it to in AD, for instance. :wink:


#7

tried clicking a SVG file as someone suggested, and that did worked to load up inkscape. So maybe its as bbum says, and it was just a temp notice that the app won’t be supported at some point…?


#8

It is a one time notice, yes. You’ll get one notice per app that is 32 bit letting you know that, unless the developer fixes it, that app’s days are numbered.

At least, I think it is once per app. It may bug you again after some relatively long period of time.


#9

Definitely check for xQuartz updates (& settings) after a macOS upgrade. Inkscape, too of course, but folks tend to forget about xQuartz.


#10

Works fine here… there were rumors that 32 bit apps would no longer work with Mojave, but obliviously not the case. Might need to be more cautious with upgrades going forward, however.


#11

I really wish someone would do a native compile of Inkscape. GIMP native is so much faster and doesn’t suffer from open-apple envy. I’ve seen mention of a “homebrew” native compile but I haven’t tried it.

BTW, if you have multiple monitors xquartz has a bug/feature with mission control. Been struggling with that for a week since I updated Chrome, had to go back to version .60 or so to get full-screen to work along with inkscape. I’m still running Sierra (due to incompatibilities with Indigo) which requires disabling ‘desktops use separate spaces’ for xquartz to work. When that option is enabled the Inkscape window is hidden, you can see it in mission control but you can’t focus it on any desktop. Newer versions of Chrome blank out additional monitors in full screen mode without setting that option. I usually stream to my second monitor via Chrome and who wants to watch football in anything other than full-screen mode?


#12

This topic was automatically closed after 32 days. New replies are no longer allowed.