Inkscape scaling and DXFs (not the metric thing!)


#1

Well, I realize this isn’t an Inkscape forum, but I’m using a few different pieces of software and everyone blames “the other guy” for these types of issues so I thought I’d check with y’all…

I have a DXF. Thank god, it includes a reference shape.

When I open it for modification in DraftSight, the reference shape is the correct size.

If I open it in Inkscape, with scale=1, it’s wrong. The reference shape is 0.049" rather than 1".

OK, so I open it in Inkscape with scale set to 20 (0.050x20=1.0). The reference shape is now entirely wrong – it’s 0.801 high by 0.798 wide? Scale=1 works nonlinearly?

Right, so now I’m thinking DraftSight has an issue, and when I modified the file and re-saved it, I broke something.

So, back to the original file from four years ago. Open it in Inkscape at scale=read from file, and the one-inch reference shape is 1.07. Worse, some of the features that I know (say, a 0.250 circle) are scaled differently (eg: 1.04x the correct size, not 1.07).

Now is the tricky part…

…if I open the original file, as above, untouched, with scale=read from file AGAIN, the reference square is now 1.01x1.01. Not 1x1, which it should be, and not even 1.07 (as it was above).

…if I open the original file, as above, untouched, with scale=read from file YET again, this time the reference square is 1.07x1.07. Not the 1.01 it was just ten seconds ago.

Um, thoughts? My DXF compadres blame Inkscape, and the Linux dude I know blames DXF. Me, I blame everyone including myself.

I’ve also used FreeCAD and Fusion360 to try to troubleshoot, and the less said about those two the better. I think I may have crashed an Autodesk server node.


#2

Argh, that remark was from a different file. The one I’m worried about at present was 0.050.

…yes, there is more than one of these files, out there in the darkness with sharp teeth.


#3

Be aware that InkScape includes the stroke width when it shows overall dimensions.


#4

There is a selection in Inkscape preferences to change that.

Go to Preferences>Tools. Select Geometric Bounding Box instead of Visual Bounding Box. Measurements will no longer include the stroke width.


Inkscape and Stroke Width and Kerf, Oh, My!
#5

Thanks, very useful tip.


#6

This is an excellent tip, and solved probably half of my issues (embarrassingly enough, some of my notes from a few months back mention this setting, but evidently I forgot about it? Argh, I’m an idiot!)

I’m still perplexed by the scale subtly changing when I open the file, and there’s some disappearing geometry, but at least some of the wackiness can get nailed down, many many thanks!