Inkscape Trace Bitmap Showing Gray?

I’ve used the “trace bitmap” function a lot in Inkscape to quickly pull images for engraving but now it seems that when I go to engrave them the image is outlined black with gray fill on the left side of my dashboard:
Ham Gray
However, when I just take a screen shot of the image and go to engrave that jpg I get what is typically correct:
Ham Black

Am I simply forgetting something in my settings or when I create the file in Inkscape. I tried to do a design a couple of days ago that seemed to add a lot of outlines. Here is the original design:
Here is how it turned out (Ignore the variance in engrave color):

Any help would be appreciated because as I said, I’m pretty sure thee trace function has never done anything like this before.

Hmm, can you upload the actual SVG, not a jpg screenshot?

It might be an issue with the way trace did its thing.

– edit or SVGs, because this looks like 2 different designs. They probably have two different issues.

Which logo would you like? the Scout image was just a quick mock up of the one I made since I deleted the original. Here is the star logo as an SVG. Ham STP
I’m thinking it has something to do with the trace, but I can’t figure it out for the life of me.

Hmm maybe they changed the UI slightly? I just went and looked at an older vector-based engrave job, and it’s grey-filled too. I can’t tell you if it was always like this and I just never noticed or if it’s new.

In any case, a raster still showed up as a black fill.

The Scout image … that one would have been good to have the original SVG. Did you design it yourself, and if so, how? I suspect that the numbers had some sort of path issues that weren’t easy to tell just by looking… maybe overlaid shapes.

I made the design myself, it’s just a trace bitmap of the supplied scout image basically. So here it is traced:
Here is one that was made in inscape using the text tool then “object to path”
Scout Ink
And here is how either one shows up with the gray out making me think it’s going to mess up with the extra lines again.

Hmm, that second one that is text to path doesnt look like anything should be wrong exactly.

I might scale it down in the UI to be like 1" square and give it a whirl, see if it engraves properly.

(In fact I’m gonna do that right now, just to help you rule out[or confirm] that it’s something super specific to you.)

Looks fine to me:


Your trace bmp file gives me this:

lots of layers on engraved letters stacked on each other. That’s probably why its gray. The jpg is a different format, it probably isn’t broken down like this one. Don’t know about Hamiliton himself though, there aren’t multi-layers of him. It’s just a wild guess. I thought maybe it was gray because there were no settings assigned, but that doesn’t seem to be the case.

I’m not seeing anything strange with the scout file. It would look just like how @evansd2 printed it. Has it changed from when you’ve first engraved it? Because I don’t see all those extra engraved areas that is creating more outlines. Check out your file in outline view in Inscape. It helps to see what is hidden beneath the colors.


Oh yeah exactly what @cmadok said. I didn’t even look at the text in that, I assumed you traced the star and generated the text. The text looks like you did stroke to path a couple times or something, lots of nested paths.

1 Like

I appreciate you both looking into this. I’m going to mess with it a bit more to see if I can figure it out on my end. The “SCOUT” one I just posted was a new creation from just typing it out in Inkscape and not the original file. I wasn’t going to run it again or need it again so I just deleted it after I ran it.
Either way, even with the star logo, that still appears gray on the layout and I can’t figure that out.