Inkscape Update: Version 1.1.1

Wanted to post this here in case anyone hasn’t checked the site recently. Inkscape has posted a massive update for version 1.1.1 and it fixes a TON of issues! One of the nice features I’m seeing as well is native handling of EPS files(which is a bonus to me because I have several of those file types from a vector service I use)

Change log for anyone interested:

Bug fixes



  • Clicking the resize separator will toggle visibility of docked dialog (Commit 3c8683, Bug #4676, MR #2969)
  • Welcome dialog:
    • Fixed a paper size typo (Bug #2570)
    • Renamed some confusing device size names (Bug #2570)
    • Removed an unnecessary warning when choosing the keyboard shortcuts set (Bug #2529)
  • Transform dialog: Matrix tab no longer stubbornly insists on using display units instead of the units the user selected (Bug #2429)
  • Text and Font dialog: Font features load in under a second, instead of minutes for fonts with lots of font features. More font feature glyphs shown too (Commit 0dacc4, MR #3449)


  • Fast crop: Transparency is now respected when applying the Filters → Fill and Transparency → Fast Crop filter (Bug #2419)


  • EPS: Users that have installed Inkscape in the snap packaging format can open EPS files again (Bug #1406)


  • Optimized SVG: Save as → Optimized SVG works again in Linux AppImage (Bug #1738)


  • Start / end markers: A bug was fixed where the path tip protruded over the arrow marker’s end (Bug #2593).


  • Help menu: Now using a different set of web links to link to the documentation from the Help menu (MR #3325)


  • Snap remembers user preferences even when the home directory is not available to the snap. This may occur in LDAP, SSSD, or other set ups where there is a modified nsswitch.conf and NSCD is not acting as a proxy to snaps. (MR #3474)
  • Build fixes:


  • All templates generated from the ‘Welcome’ dialog now use a document scale of 1, making it easier to hand-edit documents created using them (Bug #2728)


  • Measure tool:
    • Settings for font size and precision for the Measure tool work again (MR #3343)
    • Position dialog moves handles to the right place again (Commit 1fcc33)
    • Measurements no longer reset on right click or tool switch (Commit bd9349, Commit 341a0e)

Crash fixes

Fixed a crash when …

  • … using a grid with the Document Properties dialog open on Windows. This also fixes a memory leak on other operating systems, that did not necessarily lead to a crash. (Bug #2585)
  • … trying to copy an object without ID (Bug #2714)
  • … stroke to path applied on paths with no area, fill, stroke, or markers (Bug #2502, Bug 2572)
  • … entering a space character in the ‘Attributes’ field of the ‘Clone Original’ LPE settings dialog (Bug #1709)
  • … closing a window while the filter editer dialog is floating and a filter is selected (Bug #2753)
  • … pasting 3D boxes when the 3D box tool is active (Bug #2741)
  • … multiple objects selected for spray tool in single path mode (#2740)
  • … quitting in command line or when opening windows if done before window fully loads (Bug #2776, Bug #2487)
  • … Homebrew or MacPorts used and XDG_DATA_DIRS is not defined (Commit 1a6c62)

Extension bug fixes


The following UI translations received updates:

  • Brazilian Portuguese
  • Catalan
  • Czech
  • Polish
  • Russian
  • Slovenian
  • Traditional Chinese
  • Simplified Chinese

Inkscape 1.1.1


THANKS for the info.
I sure hopes this fixes the random crashes!


How much ram do you have? If you start making massive files it will need more ram, I generally don’t have an issue with that but I will get issues with it taking forever to launch some times (and I have a beefy desktop)

1 Like

That is great! However, I don’t see any mention of changes to the outline feature that caused me to go to Gimp to do outlines of raster graphics. Though the complexities available for creating vectors from any sort of masking, will still make Gimp needed for really nonstandard vector creation.

1 Like

I only use a Surface pro 7 (Microsoft - Surface Pro 7 - 12.3" Touch Screen - Intel Core i5 - 8GB Memory - 128GB SSD) It is only used in my shop for my Glowforge and Inkscape files.
So…only 8GB.

1 Like

Ah that would do it, that model of surface was natorious for issues with graphics processing. I have a friend who uses only Photoshop style programs on his and it drives him nuts at times.

Just downloaded the latest version and it comes up as 2.0 (for the Mac - I don’t know about PC)


Snagged it, thanks for the heads-up! Also donated, Inkscape’s the best.



As a mac user I stayed on Catalina because back when it wouldn’t work on anything more recent. Do you know if I can upgrade to a newer operating system?

1 Like

I think the most recent is Monterey which was just released in October to replace Catalina.


I stayed on Mohave because I didn’t want to fuss with upgrading Inkscape and/or the Mac. It seems every time I update my old stuff, it sets off a domino effect of improvements that are really not improving my life.


Your download may have been diverted to a malware site.

Even the latest development version is 1.2.0.

1 Like

I just did some searching. Since Catalina, there is Big Sur and then Mojave. Comments are still iffy about Big Sur, so I think I’ll stick with Catalina for now.

1 Like

I just installed Inkscape 1.1.1 on a new M1 MacMini running 12.1 (Mojave). It asked to install Rosetta (presumably because of the architecture change for the M1). After that, I ran it and spent about 5 minutes screwing around editing paths, doing boolean operations, etc. Everything worked okay.

That said, I see that the Inkscape site explicitly says it is for Mac OS 10.11 - 10.15 (i.e., not 12.1).


Good to know.


This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.