Introducing Snapmark (September 2018)


#728

One thing you can always do to check before you attempt an engrave is to just lightly score the Snapmarks first, to see if they fall on the original ones. That doesn’t look like it was even close.

First, take the tiles out and let the design snap into place using just the jig on the bed. Make sure to use the jig thickness for the snapping. Test the alignment with the light score of the marks. Then carefully place the tiles in the holes without moving the jig, and make sure that you have set the correct thickness for the Engraving step (only) to match the thickness of the tiles.

You either need to make sure that the jig surface is at about the same height above the tray as the engraving surface of the material, or do some manual overrides for the focal point in the engraves.

There’s a write up on it here:


#730

Sounds like something to do over the weekend…


#731

Should I be worried that I don’t have Snapmark yet? By worried I mean does that mean that my machines calibration data is not good enough and therefore not as good as those with Snapmark. Asking for a friend :wink:


#732

:smile: Congrats!

Naaaaw…it might mean that your placement calibration is better than everyone else’s has been. You never know. They might be beta testing on the ones with bad placement to see if it improves. :wink:


#733

Finally got Snapmarks! Immediately ran into some trouble though. I was working through the pencil tutorial but things went wrong when I tried to snap the design.

It appears that the system notices my snapmarks as the head moves first over one, then over the other, but then nothing. The head stays over the second snapmark and the UI doesn’t snap the design.

When I try again, without recalibrating the machine, the head rams into the right side of the bed and either the stepper motor is skipping steps or the belt is slipping.


#734

What design software are you using to save your snapmark file?


#735

I’m using Inkscape, but I’m fairly confident that the machine is recognizing the snapmarks both in my design and on the workpiece. When I uploaded a pdf version that inadvertently cut off the snapmarks, it corrected me immediately by saying my design had no snapmarks. I got no such message when I uploaded a plain svg version and the head hovered over the snapmarks already scored on my workpiece.


#736

I had the same problem for a long time before we figured it out. Go to Edit -> Preferences -> tools (I think) and look for Visual Bounding box versus Geographical Bounding Box (I’m trying to remember the names but I don’t have access to Inkscape right now). You want the Geographical Bounding Box selected. In Inkscape, when you size your snapmarks, the visual bounding box will go to the outside of the stroke, NOT the actual line. The other option will give you a correct size for the snapmark.


#739

You guys might want to check out the Notes here:

You likely have to resize the marks in addition to checking Geometric Bounding.


#740

The Snapmark sizes are the correct sizes, I tried the .3322 and .4047, and they automatically get rounded to .332 and .405.
At first I noticed the right snap mark was higher by about .001, so I made sure they were aligned, but still no luck.

EDIT:
Apparently as a “New User”, even though I’ve been on here for just over a year, I’m limited to only three replies in a topic.

LAME! How long do I have to be here before I’m no longer “new”?


#741

Got to go feed the cats (and me). Will come back in a bit with something to try. :smile:


#742

Love the positive vibes…I’m naturally glass half empty. Having said that I did wait nearly 3 years for the Glowforge so I must have some positivity in me :wink:


#743

Whoa… Looks like we got some jazzy new changes in the Snapmarks routine!
That darkened screen makes it a lot easier to ignore slight variances in the placement.
(I’m assuming it’s supposed to be doing that now… @bonny.) :wink:

Update @bonny: Okay, now I know that I am officially losing my mind…the darkened screens only happened once, and have not repeated. And I didn’t think to do a screen cap at the time. Snapping was perfectly consistent though, so I thought it was by design. Maybe it’s associated with not coming completely out of the Sleep mode by opening the lid on the machine before sending the results of the snap to print.

It was odd. (My first print today…roughly 11:30ish or so CST.)

Okay, I just tested this Inkscape template and it snapped perfectly. Try using this one if you have Inkscape, and are having trouble with the snap. Make sure your Geographic Bounding is selected, and save the modified file as a PLAIN SVG.

Snapmark Beta_Inkscape_Template.zip (1.1 KB)


#744

@Jules wasn’t the size of the Snapmarks adjusted a little?


#745

When?


#746

That’s what i’mm looking for?


#747

No, I don’t think so. The actual size of the marks hasn’t changed, because that one that I just posted was built off of an old copy of the original template that Bonny made public.

There has been some confusion about what size the marks have to be, but a lot of that has to do with the Visual Bounding versus Geometric Bounding issue in Inkscape.


#749

about 12 days ago…

julybighouse:

At a Scale of 96, the snapmarks need to be .343 x .417 in order to work.

In Inkscape


#750

That was a misunderstanding. It had to do with the Visual Bounding being checked. Once that was taken out, the sizes were as they had always been. :slightly_smiling_face:


#751

Ok, I have no clue now. I’ve tried everything exactly as stated. I thought maybe because I saved them as and Inkscape.svg, that was it, so I save it as a plain.svg, still no luck.
I believe I’m at the mercy of @bonny now.