MakerCase seems to be gone

Anyone know what happened to MakerCase? I tried to go there to make a box and the site won’t load. I’ve tried a few other site but nothing is as good as MC

1 Like

Works for me as of 4pm MDT: https://www.makercase.com

Have you tried clearing your browser’s cache and reloading the page?

3 Likes

@MoeForge you may want to clear your browser cashe it loaded just fine for me.

5 Likes

oh crazy! thanks will do!! I was so sad that it didn’t work

2 Likes

I’m glad you brought this up, because I didn’t know about this site.

3 Likes

Oh you’ll LOVE it. Its so fun. I still cant get it to open in Safari but it works in Firefox.

1 Like

I did find that clicking on the Marble Maze Generator in Chrome (Mac) caused the tab to crash and the whole page was unresponsive until I killed the tab and started over.

1 Like

Me too, Chrome/Win10. Something wrong with their scripting.

[edit] Hmm, Edge doesn’t work either.

Maybe don’t click the Marble Run pane.

Works great for me, you may want to restart your computer

There is alway boxes.py it has more options. But It doesn’t do a fancy preview.