Newbie issues with inkscape


#1

I am having problems uploading inkscape rendered images into the GFUI, and am not certain what I am doing wrong, so I am seeking help from the awesome crowd GF enthusiasts here. I am attempting to “save as” and selecting plain SVG. When I attempt to upload the file (which is just a simple solid circle about 1/8th of an inch) I get the cant upload file of this type error. The icon next to the file looks like the inkscape symbol, for what it is worth. I am even struggling to drag and drop the file I am attempting to upload here so it can be seen by others: why%20doesnt%20this%20upload%20for%20me


Urges
#2

Tried drag and drop onto the Dashboard? :slightly_smiling_face:


#3

Your computer may recognize it as an Inkscape file, but does it have the .svg extension in the filename? Just a first guess.


#4

Yes, and thank you for the response. Dragging and dropping yields the same result. I can’t even link the files in this forum section. I had an odd error in inkscape after playing around with settings and deinstalled and reinstalled. It seemed to clear up the issue I was having, but now I am struggling through with this new issue. The help is appreciated, I am at my wit’s end.


#5

You have the latest version of Inkscape installed? (Older ones had some issues.)

What browser are you using?


#6

I am using chrome and inkscape .92.2 which I think is current. I have obviously botched something up, files that have uploaded for me before are giving me trouble now too as I try to reupload. Some work, some don’t.


#7

I do not see the .svg in the filename… I don’t get why, I clicked to save as a plain svg.


#8

You can try just adding “.svg” yourself or “save as…” Again and include it.


#9

forgive me if any of this is too basic or you’ve already done these things, but here’s what I’d try:

Click on your circle, look at the X and Y. If they aren’t in the low positives, your circle may be way off the working area. Not sure if GF has a limit on this, but maybe?

Converting to plain SVG is pretty much a thing of the past, it’s a good thing to remember, but I haven’t used that since the very early days (oh so long ago, November!) so while it may be a dorked up SVG, I find it way more likely that you are at like -1000 mm X coordinate or something. I cut plain inkscape SVG all the time with no issues.

Try a control-A in your doc to see what it selects. Just be sure it comes up as one object or path. You might have some weird something or other in there that is causing the issues. Clipping paths or whatnot.

(You might want to upload your file here for us to look at it. Zip it and upload it maybe?)

If it’s a circle object, try converting to path. Unlikely to change anything but worth a shot.

Try making a whole new document and pasting your circle into it, and save it as “test.svg”. See if a new file does it.

Are you sure the fill and stroke are set the way you want it? No fill and a solid stroke (no pattern) will yield a cut.


#10

Adding.svg to the file name didn’t affect it’s ability to upload. I did do as “save as” and selected plain svg as the type. I am feeling pretty stupid and frustrated by now. I have had a difficult beginning so far.


#11

circle.svg.zip (598 Bytes)

Zipping the file got it to at least be linked here. I am going to see if it is huge like you asked. I was having an issue before de/reinstalling where the circle I was attempting to draw was humungous, though it looked like that was fixed. Maybe not. I am not sure what caused it in the futute other than my lack of expertise.


#12

Hmm it’s a group of a single object: a solid fill ellipse (not a circle, if you didn’t know) with no stroke or fill set.

The file name is circle.svg.svg

I grabbed it, ungrouped it to get to just the ellipse, then set it to a path, then converted it to no fill and black stroke, and it uploaded fine.

I’ll zip it up and post it in a sec.

newcircle.zip (923 Bytes)


#13

The only thing I saw that looked really wrong is that the fill and path were both unset, which was something I thought only happened with clones?

What’s really mystifying is that I was able to drop it in without changing anything and got no errors. Using Chrome, on a PC. Granted since it was a black filled ellipse, it thinks it’s an engrave, but there you have it.


#14

Yeah, I was able to drag and drop it as circle.svg.svg too. And it showed up as a circle engrave.


#15

Hrmm… it still won’t upload for me. I cannot drag and drop the new file either, which yes I extracted from the zipped newcircle file. This sort of computer issue is what makes me weep in frustration of my lack of understanding. What do I have set differently than everyone else?


#16

Well, I’m going to upload a zipped Illustrator file - unzip it and see if you can load it.

Squaresville.zip (556 Bytes)


#17

I tried to drag and drop with into the GFUI a couple times back in December without success and haven’t tried since. I was missing something too.

That said, I’ve never had an issue using the upload button or add artwork button.


#18

I can download and unzip the squaresville file, but I get an unexpected error when attempting to drag and drop on the dashboard and to upload it =/


#19

It does not upload either. I have never before today had issue with either dragging/dropping or the upload key.


#20

You might try turning off the machine, moving the head underneath the lid camera, and then turning it back on and letting it re-calibrate.

If that doesn’t do it, you can try resetting it…hold down the Print button until it turns teal (ten seconds) then turn off the machine, move the print head slowly underneath the lid camera, and turn it back on, then let it calibrate again. (Might take several extra minutes.)

Sounds like bad communication with the mothership.