Odd SVG behavior

Hoping someone can give me a clue on this one. The attached SVG file is a 20"x12" art board. When I upload it to my GF, the UI reports the size is enormous - like 780 x 592 inches. Some of the shapes that I want to cut appear to be missing, but the size of the existing art isn’t actually changed. I’m sure those “missing” shapes are somewhere in that 780x592 inch space, but I got tired of scrolling around to find them.

I have several other files the same size with different shapes and those all work just as I’d expect. I tried copying and pasting the art into a new file & got the same behavior. Any clues here?

PS - designing in Illustrator. Thanks!SHEET3

Weird. I see now that the preview image of the SVG is also missing the same art. That open space in the lower left should have some art in it. Uploading PDF here to see if it looks right.SHEET3.pdf (159.2 KB)

Your pdf throws a clip path error.

I don’t have an answer for the svg weirdness - but since you’re using AI you can copy/paste directly from AI to the GF dashboard/library screen and skip svg altogether.

1 Like

That’s the proper size, but there is art missing.

And per your note below, I’m gonna have to figure out what a clip path error is and how to fix it.

(I’m adjusting someone else’s design, so there could be something odd in there I’m not seeing. My AI skills are rudimentary, at best.)

I found I had a bit of time to kill so I downloaded the file and there is something way out. I could not even get to show on the AI Screen. I copied the part you want and deleted the rest. try the attached file and see if that fixes it.SHEET3 Test
Hope this helps

I think I miscommunicated … when I import to GF the missing part is what I’ve circled in orange in the attached image.

While I’d love to figure out what happened, it’s really nothing to spend much time on. I can just import a PDF into GF and cut from that. Thanks!

Oh? I didn’t know that was an option.

1 Like

The artwork is probably a bitmap. Those can be “linked” or “embedded” in the svg.

I’m so sorry to hear about the snag you’ve experienced with this particular file. I’m glad to hear that after a little bit of research you were able to narrow down the trouble, and find a work around.

I’d like to keep this thread open for some additional discussion, so I’ll be moving the post over the “Everything Else”.

Please do not hesitate to reach out to us directly at support@glowforge.com if you happen to run into any more trouble. We’re here to help :slight_smile:

I found your missing bit. It was way down in the lower right corner, far beyond the selectable area in AI. To find it, I Selected All, then changed the width to a value of 5. I did this three times before the bounding boxes would fit into the AI scratch space.

Screen Shot 2021-01-15 at 11.33.36 AM

I grabbed the lost bit, moved it back into place in the design, and then selected everything (now contained within the green outline) back to the original size that the green outline came in at: 19.45 x 10.95.

Seems to load fine now into the GFUI.
tile tray 2 of 2 Fixed-JBV

2 Likes

I tried “accidentally” shifting something that far off the artboard by typing ridiculous numbers into the X,Y positions, and my feeling is that does not seem to be the likely culprit. I’m also a little surprised that the bounding box extended above and to the left the main artwork as well as below/right, but I could not find any elements up there. :man_shrugging: