Shift key to constrain in app.glowforge


#1

Hi there,

I don’t know if it’s only me but would be nice to have the “Shift Key” to constrain horizontal alignment as pretty much every design software! (I know it’s not a design software! :P)
But like the rotation that goes in certain angles would be really handy to have the shift key to constrain alignment Vertical and or Horizontal!

Nice comments about it already…

What I meant was to hold down shift key and move the object up and down and or left right constraining as it already does with the rotation 45º.

:slight_smile:

I don’t use Inkscape as it is (FOR ME) too old look like…

I use Illustrator as I have no problema designing with it and it’s much faster and less “buggy” than Inkscape!

Just an idea!

Thanks! :slight_smile:


#2

We’re always scolded not to design in the app, but some simple features like that are completely reasonable and VERY useful for getting the most out of our materials.

  • Shift to constrain dragging to X or Y (at least we have arrow keys)
  • Non-proportional scaling (please, just let me make an ad-hoc cut shape out of a rectangle)
  • Align Center, Left, Right, Top, Bottom (including the ability to align to a reference object, just steal the way Illustrator does that kthx)
  • Numerical scaling (“make the selected thing 2” across, proportionally")

Offering proportional scaling only is such a tease.


#3

Paste in place! Goes hand in hand with constrained motion.


#4

[uninformed(?) opinion follows]

… oooorrrrr, you could use the software that is purpose built for this sort of thing. It’s not a scold, it’s just … what would you rather GF spend time on? Reinventing half the wheel you have now or making the laser part better? ** How about making the scan/process part faster and more capable? Wouldn’t it be awesome to click go in the UI and immediately be able to press the glowy glow glow? (Yes, that is the technical term.)

INB4: Yes I know it’s not necessarily a zero-sum game, but there’s definitely a sum, GF doesn’t have infinite resources. Let’s not split hairs about development team organization inside GF

** Yes. half the wheel. You want shift constraining, I’m an inkscape guy, control constrains. So, not only would it be a huge effort to get it done, it would be impossible to make it everything to all users. GF is smart to stay out of it beyond the basics (though adding primitives and numerical scaling would be tip top), there’s no good path to victory for them there.


#5

Or they could go ahead and add paste-from-inkscape to the bed view and I’d need fewer things… Yes, I can save-then-add but it can be clunky isolating elements.


#6

You know… I was going to say what a nightmare that would probably be. Hell, it’s a chore to even open Inkscape on my Macbook. Half the time its just an empty XQuartz window and Inkscape won’t even load.

And I’ve always had pretty much zero luck anyways with even copy/paste from Illustrator, so it’s not even a part of my workflow.

But, I loaded up Inkscape. Or tried. It took a couple of tries. Did I mention that using Inkscape makes me want to jump out the window? I only have a single story house, but still…

Inkscape finally figured out how to become visible. I made a squiggly line. I can’t use a keyboard shortcut to copy it (command-c) like I would normally, so I had to go up to the menu to copy. And then I couldn’t paste it into the GFUI with just command-v, but I could go to Edit > Paste .

Lo’ and behold, it prompted an upload window that went away automagically and a squiggly line appeared in the UI.


#7

Have a reasonably powerful Windows 10 laptop and Inkscape usually gives no indication that it is loading for 30 seconds. After that it runs like a champ.

Trying to load it 2 or 3 times because you didn’t think is was working is a big mistake.


#8

Actually yes I DO want the to spend time on some of those things because otherwise I spend a lot of time tweaking and reloading files and I am sure I am not alone since this comes up every week. Even you said you’d like numerical scaling and primitives. So the disagreement is about where the line is drawn.


#9

It loads differently on the Mac.

Opening the Inkscape program actually opens up XQuartz which then opens Inkscape.

I can let it sit there all day long and it will almost never open. Sometimes it opens on the first try. Other times I have to kill the Inkscape process and then restart it to make it appear. Other times it says that it is open but nowhere to be found on any of my 3 monitors.


#10

What’s the sense in drawing a line that needs to be rotated, moved and scaled. :wink:


#11

So the shift key is already used to constrain things in the GFUI

When rotating an object shift will snap the rotation in 45 degree increments.

When you use shift with the arrow keys you move 10 increments instead of 1 increment at a time.


#12

Nice! I just recently read about pasting into the list-of-designs view, but thought the bed view was still in the hopper… The paste operation may well work for Affinity too, though I don’t own it.

BTW, I run Inkscape on a mac with no issues. It takes about 4 seconds to appear the first time, but no issues beyond that.


#13

Yes if you build everything with a couple of 19" horizontal Linn 11 inches apart the rest can be arrayed as needed. Then if you are using the pass through you can use that line on the bottom to cut off that bit and go to the next.


#14

Worth linking to this thread:

Similar topic.


#15

Thanks for the suggestions! For future reference, the Problems & Support category is the place to get them in front of the team prioritizing work. When people posts requests here, we assume they want to discuss it with other folks, not actually request it - although since I saw this, I’ll pass it along.


#16

I run 2 monitors. Inkscape is dicey in “Extended Desktop mode” switch to Mirroring displays and see if the Inkscape window appears.

It drives me batty, but I run my two monitors in mirror mode while in Inkscape. Some Deep under the hood things need to happen in Xquartz and Inkscape to make extended desktop work I guess.


#17

On my Macbook, copy/paste functions work fine as long as I remember to use the “control” key instead of the “command” key.


#18

I’ve started opening it by double-clicking an SVG file instead of clicking on the program icon, even if I really want to create a new file. It starts up without a hitch and then I can just open my new file from the menu and close the one I didn’t really need open. :stuck_out_tongue_winking_eye:


#19

I hope nobody ever really scolds. It’s just the simple matter of, as the saying goes, using the right tool for the job. The Glowforge app is, IMHO, nothing more than a glorified printer driver. You wouldn’t ask HP’s printer driver to assist you with designing anything, because that’s not what it does… it prints… that’s it. Think of the Glowforge app in that respect and you’ll (almost) never be disappointed by it.


#20

Though, I can tell the HP (well, Canon) driver to array.

Or, print multiple copies:
43%20AM

But, I do agree. Design work should ideally be done in design programs. I can also drag the print around in the Canon print screen, but I don’t expect much precision when doing it.