Silly problem


#1

OK, I am very comfortable using the GF and Inkscape, for some reason I can’t get this file to load??? it is just a rectangle. Could somebody take a look and and see what I’m doing. other parts of the file are loading fine!
jig|508x295

I didn’t want to open a support ticket so I put it here


#2

Can’t download that @tom - can you zip it first?


#3

:bouquet:^^^


#4

I’ll go out on a limb and say the “|” symbol in the filename is breaking the attachment…


#5

That’s not the filename. The pipe and dimensions are autogenerated by Discourse. Best answer is still zipping before uploading.


#6

sorry I should know better.jig.zip (2.3 KB)


#7

I’m not sure what’s causing it. Yours doesn’t open, but if I take it into Illustrator and resave it, it opens just fine.

What program did you use to create it? (Oh duh! Inkscape.)

Did you copy and paste parts of a file from somewhere else? (Thinking something downloaded from the internet - there are some other hidden layers in there.)


#8

Other layers are mine, if I open them and save it with the rectangle hidden from view it opens fine in the GF app. The crazy thing is I redrew it from scratch assuming something got corrupted and it still didnt work???


#9

here is the total inkscape file
All.zip (5.6 KB)


#10

There is an empty Base layer in the stack that we’ve had trouble with before, and I can’t remember what the fix was for it. But i think it had to do with having the correct settings for saving the SVG and how the interface rejected certain descriptive information. (I’m just not really familiar with setting those up in Inkscape.)

You’d probably need to ask @Chris1, @jamesdhatch, or maybe @jbmanning5 . I think they were the ones who figured out what was causing it.


#11

OK this is getting crazy, I just need to cut this as a jig to hold parts in the right place, I put every thing in one file so every thing would line up. Since I couldn’t get it to load the file with the jig part open I decided to open a new clean instance of InkScape and just draw a rectangle the same size and line them up manually, I got the same error???


#12

I feel like that’s just an Inkscape thing. The structure always opens odd in Illustrator for me.

Not at computer to look at SVG and code but are you saving as a plain SVG of Inkscape SVG, @tom?


#13

Oh, and are you using the most recent version of Inkscape?


#14

Yes plain svg and probably not the most recent release. I will update now


#15

Your large rectangle that has a teal stroke has not been turned into paths. It is still coming across as an editable rectangle. Note that the corner control points are different when you edit the path. Once I turned it into a path it loaded fine into the GFUI. Note the top left and bottom right has square control nodes and the top right has a circular node that you can manipulate for radii in corners.


#16

If that’s what’s causing it, you just caused a major “Eureka” moment! :grinning::+1::bulb::bulb::bulb:


#17

Yes he did! that solved it! thanks so much! I really can’t believe I have never run into that before…

thank you again


#18

Way to go @marmak3261! That one has been a bear before! :grinning::rainbow: :sunny::lollipop::confetti_ball:


#19

My pleasure. Just killing time before beer thirty!


#20

Those are called " epiphanies" :wink: