Size issues

So I normally draw in autocad for vectors because it is the program that I am used to. I drew a 1" square and saved it as a dxf then imported it into inkscape and then had to resize it in inkscape. I then cut it on the glowforge and brought the drawing straight in without changing size and it ended up being 25/32". I don’t really want to scale things by eye on the glowforge interface and how should I proceed so that I am cutting things at the size i want to cut them at?

The overall fix for svg from Inkscape scaling to exact sizes in the interface is to use a 12X20 artboard. Then everything will maintain an absolute positioning and sizing. My experience is that Inkscape doesn’t actually work in absolute sizes unless you do a fixed artboard like that. I’ve used other web tools for simple cut files in lines and shapes, and those come through exact in size. Inkscape generally doesn’t.

why does 12x20 work? the cutting area of the glowforge isn’t 12x20

I had the advantage of not being familiar with any other design software besides Inventor, so Inkscape has been the go-to. Saved as an SVG, and dropped in the UI everything scales perfectly. All dimensions are as drawn.

Inkscape is easy to learn, it must be because I managed it.


I don’t use Inkscape, but there is a tutorial in the Matrix about saving SVGs that work. The 12x20 art board is not required to get proper sizing—it’s a way to get repeatable absolute positioning.

The Matrix, aka tutorial table of contents:

1 Like

I believe you that it works, but they seem like arbitrary numbers

The cutting area isn’t currently 12X20, but that is the interface’s perception of the workspace, so 12X20 always automatically snaps into place with everything inside it being treated as absolutes.

1 Like

One thing to watch for in Inkscape - by default, if you click on an element with the selection tool (the arrow), and look at the width and height, this will include not only the width and height of the geometric shape, but also the width of the stroke.

So, for example, if you draw a 10" by 10" square with the rectangle took, then give it a 1" stroke, you’ll find when you click on your square with the rectangle tool it will still show 10" by 10", but if you try the selection tool it will show 11" by 11" (not 12", because the stroke is centered on the edges of your square). This drove me crazy for a long time. :stuck_out_tongue:

You can fix this by doing “Edit -> Preferences…”, then under “Tools” set “Bounding Box to Use” to “Geometric Bounding Box”.


I’ve been giving everything a 1pxl stroke

SVGs can use real units (mm, inches, etc) but many programs create unitless SVG files. The 20”x12” thing is a hack to deal with those programs; whenever you import a unitless SVG into the Glowforge UI if the aspect ratio is 20:12 (5:3) It is automatically scaled to 20” by 12”. If the SVG uses real units no scaling happens. If the file is unitless but not ina 5:3 aspect ratio, the Glowforge assumes 96 “user units” (the default units in SVG) per inch.


Why? According to various discussions it was apparently a design spec for the software. Also apparently, it was implemented such that any Artboad with a 3:5 aspect ratio (h:w) will trigger absolute positioning.

Absolute positioning simply means that it loads such that (0,0) is the top left corner of the bed as displayed in the GFUI. The actual top/left position that the GFUI will allow to be cut is (0.01”,0.01”). Even though these art boards will load at (0,0), you can still move stuff around in the GFUI.

Thanks for that! Gonna have to remember to change that setting.

Here’s the story on the 12x20:


one of my problems was i didn’t have the most recent version of inkscape and one of the things they fixed from the last version was how the size issues export to other programs

i’ve got the 12x20 background now and the correct version of inkscape and its a lot closer but still not quite there, my 1" square is 31/32"

It may end up a little bit off because of the “kerf” of the laser. Check and see if the hole you cut this out of is 33/32"? That sounds really big for a kerf width though - depends on the material, but it’s usually closer to 0.01".

1 Like

Is the 31/32" the size as it’s imported in Inkscape or the size of the cut part? 1" square tool path will produce a smaller actual part because the laser has width just like a saw blade or router/milling bit.

If that’s the import size, older versions of Inkscape tagged files at 90dpi by default so when you open an SVG in another program expecting 72 or 96 dpi, the design gets scaled. Make sure the Bitmap settings in Preferences are set to 96dpi instead of 90dpi. 31/32" is pretty close to the decimal equivalent of 90/96.



it exported as 96 pixels at 96 dpi. The hole is 1"x1", so the kerf is about 1/32". Is there a way to change the settings if you cut centered on the line, or to the inside or ouside of a line? otherwise I will just change it in my drawings from now on to offset outside cuts 1/32"

You probably want to get a digital caliper instead of using a tape to measure it because an offset of .0313" (1/32") will make everything oversized. The laser kerf is only .006"-.01" on average depending on the material and laser settings.

1 Like

The glowforge seems to always slice down the center, so in Inkscape where the lines have width you need to account for it. Unless they’ve changed something recently or I never figured it out.

1 Like