Sketchup and SVG

projectinspo

#1

I am trying to export a Sketchup Make 2016 model to SVG. I was wondering if anyone here knows how to do it.

I tried this plugin but it does nothing. I am on a Mac.
http://simonbeard.github.io/sketchup-svg-outline-plugin


#2

Just to verify, the account used for installation has full administrator rights, and you’ve Installed the Ruby file via Preferences | Extensions?

You might want to check the Sketchup community forum for other options specific to the version you have installed.


#3

Right, I should have asked on the Sketchup community. Correct, I installed via my admin account through Preferences/Extensions. It works on my old Windows laptop but I would prefer to have it work on my Mac.


#4

I’ve not tried that plug-in with 2016 yet. I’ve successfully used it in the past with 2015.


#5

It didn’t work with 2015 either for me.


#6

What did you try? I just tried it again, and it worked fine. I created a rectangle with a circle in it. Then selected them, clicked on the “SVG” button in my toolbar at the top (I think the plugin creates that button).

Clicked on “Save” in the popup, and it created an SVG for me.

Here it is in InkScape:


#7

Yep, I selected my objects, click the SVG button. Selected where I wanted the file to save. When I click the save button nothing happens. No SVG file, no feedback whatsoever.

As I said, it works on my Windows 8 laptop. Though right now that isn’t an option as I, after 10 years of having this laptop, dropped it and cracked the screen.

I will have to ask the Sketchup community. It really sound like there is something that can’t be done on the Mac version.


#8

I unfortunately can’t help with a Mac, since I don’t have one. Good luck, and if you find a solution, please post it here.


#9

I had a similar issue but it was a while back and I do not remember the exact fix nor do I have faith that the rootless situation in the new OSX had no impact since then, particularly on the ruby install. Still, it was possible in 2015 after a few fixes.

Have you checked your PATH variable? Opening a terminal and typing “echo $PATH” might reveal that the ruby gem is not accessible (I believe you should see one segment of path pointing at a ruby/bin type of folder).

The ruby install could also be affected by rootless, since there are typically a few other environment variables set by ruby, such as GEMPATH. It would be helpful if you can catch what the plugin is attempting to run.

Hopefully this can get you headed in the right direction, but the issue may be different for you than it was for me.


#10

Other extensions work. I use the CleanUp3 all the time so I doubt that is the problem. I will find a Sketchup forum to ask.

Thanks guys.


#11

Just checked that extension on my iMac running OSX 10.11.2. Extension loads in Sketchup 2014, 2015, & 2016; but as you described, does not actually export a file.

Did discover that you have to select the faces you want to export (can’t just fire and forget), but the darn thing still doesn’t work. Hope you find a solution on the Sketchup forums.


#12

I used it today with sketchup 2015 on Windows 10 Noticed that it exported only closed paths on surfaces Right click gives it as an option


#13

It appears as if someone is making a fork to fix some issues with the plugins. I will be trying it tonight. Apparently this came up fairly recently in the Sketchup forums also.


#14

I found the big black box bug when printing in the 64bit Windows version. Was driving me nuts till I found the bug report. Have to work in early version unless I switch to 32 bit. Oh well


#15

The plugin from the github fork seems to work.