Slicer for Fusion 360

Trust me. It’s mis-labeled on the page.

Sign in, click Win64 (seriously, trust me), then Download.

Run the installed and allow it to unpack the files into the default (C:\autodesk). At that point, the installer will most likely fail, telling you to manually install from C:\autodesk.

Go to C:\autodesk and run the installer. Depending on your current installs, it might want to install some MS runtime libraries. Let it. After the runtimes install, it will sucessfully install Slicer in /Programs(x86) (or whatever its called).

Please note that Slicer does not show up in the Start window under Autodesk - look under S for “Slicer for Fusion 360.”


There is no see, only do.

1 Like

I ran the downloaded Windows .EXE file twice and it installed the second time.

Yeah, you’re right! Worked fine! Thanks!
So what’s really odd is that there isn’t even a 64bit version available?!

1 Like

Maybe the installer is Universal?

I still don’t know what is going on, when I try to download to my computer I get an empty/corrupt zip but I was able to download an exe to my phone and then move that to the pc. and got a good install!?

Anyway, looks like it is going to be GREAT!

Nope. Definitely 32bit.

I have it running on my desktop and notebook.

Edit: Desktop is Win7. Notebook is Win10.

1 Like

Smooth download and install on El Capitan.:innocent:

1 Like

Yup-- same here on macOS (Sierra). :sunglasses: Just did the Win10 install as proof of concept.


I’ll follow-up here with a thumbs up for painless installation on Yosemite. :slight_smile:


Strange thing happened with mine. It said it was the 64 bit version but when I installed it (everything came down last night fine) it put it in the win86 folder as a 32 bit program would do.

as info!

1 Like