After 1 print, Spark can't seem to get past Homing

i received my new Glowforge Spark, and easily made my first print with no glitches. Since then, everytime I try to make something, it gets stuck in homing or scanning and/or I receive a message that an unexpected error has occurred. I’ve done all the things that were suggested, such as making sure that the internet connection is secure (it is), making sure that I don’t have ad blocking (I don’t), confirming that I’m using a supported browser (I am), etc., but I still am unable to complete a project. Any additional suggestions would be appreciated!

Welcome to the forum. We’ll try to help out, but if your machine is new you probably want to also contact support if it’s under warranty. They’ve got either email or phone at

Sometimes when an error occurs your browser holds on to it rather than actually reloading the page. Can you go in an clear your cache or try a completely different browser (Chrome vs Firefox vs Safari, etc.)?


Thanks so much! I did try different browsers to see if that worked, but no luck! I have also contacted support.


Good about support, and ok.

Have you tried printing the Gift of Good Measure (it’s a known-good file) in case the issue is there?

Is your bed either empty, or has a material that’s not full of holes on it?

Have you wiped off your optics with a Zeiss wipe or equivalent?


That is a clue. I have a Pro so I don’t know the details, but the normal homing/scanning for us is the lid camera trying to find a :glowforge: image on top of the head so it can set the grid points to numbers in the memory. A blurry camera or mark on the head would do it, also a strong light (often the sun through a window).

Sometimes turning the machine off and moving the head directly under the lid camera before turning the machine on again is enough to do it.


I had issues with this when I got my Spark and it ended up that the ribbon was not properly seated. However, I wasn’t able to do any print so probably not the issue but worth a ‘look’ to be sure it’s in there good!

Thanks everyone! I’ve tried all the suggestions with no success, but I am now working with Glowforge support so hopefully they can resolve it!