Air assist not working, no error *UPDATE* Problem solved-ish

Hey forgers,

In 2020 I replaced my air assist and carriage because I was having really bad flame ups. When I replaced them, I still had flame issues and just chalked it up to bad design or something and continued on my merry way. Today I had bad flame ups and posted in a GF group, and someone said you can see the fan from above so I looked and sure enough, its not turning. I am not getting an error at all. I put the old carriage and fan on and still no movement on that fan. Laser fires, everything else works fine but especially when cutting wood the flames are pretty bad.

Yes its clean, its brand new looking and the old one is clean too. I chatted with GF support and they are escalating it to an email support.

Its a launch pro that I received in 2017

Do you have photos of the print head? of different views. That is interesting its not reporting an error.


Hi MDTIC, Here are a couple of photos, I installed the carriage and fan in November 2020. I didnt realize until today that this fan has probably never ran and the tech who helped me back then said there was signs of the fan not working properly in the logs. Now I am wondering if he got a commission on the $150 order :stuck_out_tongue:

Which fan isn’t working - the one in the head, or the air assist at the back of the metal plate?


the air assist on the plate


If you pull out the white plug, are any of the tabs bent?


1 Like

Circled in red is likely your issue. The trace to the left of your print head fan is fully lifted and likely not able to carry the signal well for your assist fan.

1 Like

It does the same thing on 2 different carriages and fans, I dont think its a fan wire issue. GF thinks its the print head, if it is then I got a lemon from the factory.

I did bend that piece flat and nothing changed. I am going to borrow a friends print head to see if thats the issue, GF wants me to try a new one for $550, I’m all out of extra $550s


Bending it back will not fix it once it has been broken. The traces have to get fully replaced.

1 Like

I tried another print head on my machine and it did the exact same thing. Laser works, air assist does not. I took my print head and put it on a friends GF and it gave the air assist error. My machine does not give the error. I dont think its an issue with the head or carriage since I have 2 of each and its the same on any combo on my machine.

do you have your machines logs?

1 Like

I have been talking to a GF rep and he reset my machine and I got the error. Not sure where to find the logs. Tried my other carriage and got the same error. I’ll try my friends head later today or tomorrow and see if that helps but I dont think that the head or carriage is the issue. At least my laser “worked” before they reset it

GF reset machine to factory settings so that tells me either at some point they changed the settings or it was never right to begin with. They suggest I buy a new head since my friends works just fine and mine now throws the air assist error. I might be buying one from someone else for about $150 less than what GF wants.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.