All my uploaded projects have disappeared :(

I am printing something on my Glowforge for the first time in a few weeks. I’ve had a few problems getting back up and running again - first I couldn’t get the app to load in my browser, then I was able to get the app to load but all the squares representing the projects in my library were blank and uploading a new file was failing.

Once I was able to get into the app with an uploaded file, I was experiencing the same problem with the “set focus” command as vicky was in the thread just before this one. My first attempt at printing also failed, with the app “going out to lunch”, spinning for ~15 minutes trying to construct the job to send to the Glowforge.

Eventually everything worked itself out, I was able to set my focus, configure my file for printing and successfully load the project to the Glowforge. I printed the design successfully.

The last issue I can’t seem to rectify no matter what I do is to get all my other previously uploaded projects to reappear in my library.

I’m out of ideas of what to try… help!

If you are not in premium previously uploaded file have a limited life. You can export them back to your computer but they need to be saved there.



Do you know the shelf life of an uploaded file, and if I re-subscribe to Premium will they reappear? (e.g. can I go to Premium, export all my files and effectively recover them?)

1 Like

I believe it’s 30 days from the last time you printed, but I’m not sure on the subscribe-to-save question.

A staff member will get here (probably tomorrow) and they can answer for sure.


The shelf life of an uploaded file is 30 days I think from last use. I have not looked at those details for a while, but there would not be much use to delete them but keep them on the side, so keeping a subdirectory with subdirectories on your own computer would be the way to go.


Back during the initial days of the Premium feature rollout I believe Dan said “nope” - once they’re deleted from your account history they’re gone.


Hi @charles.sachs. I’m sorry to hear that you’ve run into some trouble with designs and the Glowforge app recently. Custom designs will remain in your Dashboard for up to 30 days of inactivity in the Glowforge app. This will only occur with custom designs, and not affect any Glowforge catalog designs and purchases. Glowforge Premium member will have unlimited storage with an active subscription. Unfortunately, we don’t save backups of the files, and will not recover with an active subscription.

I saw other members mention some great suggestions to keep the custom designs stored locally, but you can also avoid any unexpected storage expirations by loading the file into the Workspace of the Glowforge app. You can export the custom file if needed through this method, but loading the design will keep it recognized as active.

I wanted to follow up with you also to see if you were continuing to run into any trouble with the Glowforge app loading the Dashboard. It sounds this may have already been resolved, but I wanted to double check with you just in case you needed any troubleshooting. Let me know and I’ll be happy to help. Thank you!

This must be a change I was not aware of, and will have to investigate.

Hey Brandon,

Thanks for the reply. I am still unable to use the Glowforge app in Google Chrome, but I’m successful in using it in Edge.

Any tips around how I have my settings in Chrome configured to re-enable the use of the Glowforge app?

Hi @@charles.sachs I’ll be happy to help you troubleshoot any issues with the Glowforge App and your Google Chrome Browser. To help me review any potential issues, can you do the following using the version of Chrome installed on your device?

  1. Go to
  2. Look for the header that says "Your web browser’s unique URL"
  3. Click the button that says "Copy URL to Clipboard"
  4. Reply to this, and paste in the link provided

If you haven’t already done so, it may help to try and see if you are able to access the Glowforge App with another device using the Chrome browser. This can be done through any internet enabled device like a phone or tablet, and is a good way to rule out any device specific trouble.

Let’s start with those requests above and I’ll look forward to hearing back. Thank you.

Hey Brandon,

Here is my unique URL: Your client's web browsing configuration - code: H7XRL6Q -

I attempted to access the Glowforge app on my Android phone and was successful (also using Chrome there), so it is looking like something device-specific.

When I went to whatismybrowser I was told that I’m one version of Chrome out of date; I’ll update my browser and see if that doesn’t fix the problem.

EDIT: Updating from v94 to v95 indeed fixed the problem. I’m pretty good with keeping my browsers updated and there was no indication from Chrome that it was out of date by one version… have others reported issues with pending Chrome updates causing issues with the app?

Hi again. Thanks for sending me the link, and updated information. Updating to the most recent version of Chrome will be the next best step on the device. If that does not help, you may want to try clearing the browser cache and cookies (if you haven’t already done that), as well as checking any add-ons, extensions or plug-ins. I’ll look forward to the results of the browser update.

Hey Brandon,

Thanks again for all your help, the Chrome update solved my problem. I’ll be exporting all my jobs locally from this point forward :slight_smile:

That’s Great to hear! I’m going to close out this thread, but please reach out if you need anything else.