Also hung up on "rendering your design"

I just encountered this about 5pm PST on Sunday 6/7/20. I tried refreshing with no change–still just stuck in “rendering your design”.

Earlier in the afternoon I had changed images and printed without noticeable issues/delays.

So just before 5, I started to delete the artwork in the GFUI to upload something new, but in process of doing that, I deleted all visible, but still showed some artwork in the list (downloaded from the trial library) as active, so I zoomed out to try to find if it existed off my active field. That’s when it went into “rendering your design…” and there it has stuck.

I checked the other recent post on this, and did as suggested and copied the URL from “”.

(Firefox 75 on Windows 10).

Update: 9pm and still no change–stuck on rendering…

I’m so sorry to hear that you’re hitting this snag. I appreciate you sending over your browser information.

After reviewing the browser information, it appears your Firefox version is out of date. Would it be possible to see if the same error occurs when utilizing an alternate browser, such as Microsoft Edge or Google Chrome?

Please let us know if the same behavior occurs when utilizing an alternate browser, and we’ll send over the next best steps.

Will try–and I may have skipped the last Firefox update last week, but it did update within the last month, but it’s still odd why my GF worked fine with this version browser many times until late yesterday afternoon…

Update, 11:30am PST: Firefox only upgraded to v 76, having trouble getting to 77. But did start up on Chrome, and good news, it appears to be back to operating OK. (Same computer). Whew.

Curious though why the SNAFU with Firefox? Just my system–or something in their “patches” causing issues? Haven’t had issues with timing of prior updates before–esp. since my “automatic” upgrades are a version behind!

Thank you for attempting to utilize an alternate browser, and for updating Firefox. I’m so glad to hear that everything appears to be working correctly.

The trouble is most likely due to various updates provided by Firefox, and the patches you referenced.

I’ll close this thread for now, but please don’t hesitate to reach out to us directly at if you run into any of the same trouble. We’re here to help!

1 Like