Another unit stuck on focusing

Posting as want to get a ticket going–I’ve read many other threads after I finally encountered the dreaded stuck on “focusing” since yesterday afternoon.

Hadn’t used the machine for a while, but able to run a handful of small jobs, and then stalled out on “focusing” when tried to run another job (same material as last job) and GFUI showing camera image from end of my last job.

I’ve cleaned everything, checked all cables & connections. All look good. Reset my wifi router (as well as multiple power cycling & refreshing the GFUI). Air flow clear and functioning.

It did get really humid here yesterday, though wasn’t hot (maybe low 70s).

This morning I even decided to test disconnecting the printer cable from the head & that causes the button to glow orange/red. Reconnected & tried many times again, and no error messages, no button color, just “focusing”.

Note: I did have a new piece of leather on the bed when it got stuck, and reading another thread, removed that so it’s just the crumb tray, hoping maybe the material confused it. Nope. No change.

So will appreciate logs being checked and ideas for “what next”.


1 Like

Cleaned the lid camera? Did you try it with a fresh sheet of Proofgrade in the crumb tray? An empty bed can be an issue sometimes, depending on the lighting. And how is the ambient lighting? No bright lights washing things out?

Sorry that you have encountered a problem.

Thanks for the ideas–yes, the camera cleaned (always do part of my routine), I had considered ambient light, so closed curtain to make sure, though it wasn’t as bright a day as other days it’s run (not long after I got my unit I put window shading film over the lid so the laser is not as bright when I am sitting next to the unit (where my computer is), so that also helps cut down ambient light into the unit, too).

Will try putting PG into the tray–haven’t tried that yet!

And thanks–I rarely open the lid very high, so minimal flexing and no visible signs of damage to the lid cable, but that doesn’t rule out a cable issue… Have a new neighbor in apartment bldg next door, so would not have been surprised with “offline” issue (again), but still could be related to wifi, too, I guess.

1 Like

Whew! Seems to be OK now–though have yet to run a job again.

I put a sheet of fresh & flat PG med maple ply & pinned down. In & of itself, no change. Power cycled & refreshed… nothing. It did recognize going offline & when lid opened, so not a communication issue.

So decided WTH, gently moved the head and arm to about center–and hooray, Buckaroo went from focusing to centering, and made its way back home and recognized the PG material. Hooray!

Would still appreciate the GF team letting me know if anything in the logs indicates it was some error popped up, or was indeed just got “frozen” (due to a light or high humidity or other issue in my environs), and wasn’t able to reset itself after those factors mitigated. Or if my action to move the arm/head is OK to try if happens again, or not. TIA.


Are you turning it off when you move the head? (Just checking.)

Not sure if I did that time… but it’s stuck again. I had taken the PG sheet out before I turned the unit back on. Will now turn off and move the head and see what happens when I power it back on… Ok, seemed missed the focusing bit, but went into centering pretty quickly, did its thing, homed & then scanned & image is of the bed as it should be (I do have a bit of tape on the bed I’d used for positioning a few jobs back).

So will power cycle again: and it’s still focusing–hearing the ticks cycle & the fan, but nothing else. So back to the PG sheet, and try again (and turning room light off, even though never an issue >18 months before). Nope, PG sheet doesn’t make a difference. When head is at “home”, it’s stuck on focusing.

Will try next uploading an image, moving the head/arm to center, and see if can get as far as print ready…

So after putting PG sheet in again after centering the head manually (unit off & GFUI showing offline), powered the unit back on, it focused & centered, moved to home position, scanned & recognized the PG ply & the image I had uploaded. (the room is nearly dark, so ambient light is not an issue, and no runs since I last cleaned it).

Showed ready, so I hit print, got the magic time & lit button, and it etched the artwork as intended. So the head can move–but now it’s back in “home” after completing the job and stuck on “focusing” again. (this was about 1pm, PST 7/7, for those looking at the logs).

So something in “home” position is preventing the unit from completing the focusing so it can get to next steps of centering & scanning. & printing.

At least I know I can get it to run, but not sure if I could be causing more damage by manually moving the head/arm to trigger the centering action?

1 Like

I also want to note that I’ve not yet run the calibration routine that was released a few weeks ago to aid in improving accuracy–had some trips and then forgot…

1 Like

Hi @bansai8creations, I am so sorry you ran into trouble again!

I extracted the logs from your Glowforge to investigate the problem, and it seems like your unit is running into trouble during the calibration step in which the lens focuses inside the printer head (you may hear this when it’s happening - there’s an audible “ticking” sound as the lens moves up and down in the head). There are a few different reasons this error may be occurring, so would you mind checking a few things for me?

  1. Please check the printer head lens by following steps 1-5 from these instructions: If you see anything unusual such as damage to the lens or debris in the printer head, please take a photo of it and attach it to your reply
  2. If you are using magnets to secure material to the crumb tray of your Glowforge, please remove or reposition them and try again. Magnets placed closed to the printer head may cause trouble during calibration
  3. Check the connection of the printer head to the white ribbon cable in the printer arm. Turn off your Glowforge, unplug the head, and plug it back in. Note whether the cable plugs back in securely and whether you feel it “click” into place

If this does not resolve your issue, please let me know and we will investigate this further.

Thank you Jeff, I just finished a thorough cleaning all the entire machine & exhaust (per 1), removed all from the crumb tray, and just restarted Buckaroo (1:20pm PST). And still focusing.
(Lenses/mirrors all in good shape, exhaust fan & outlet wasn’t too bad, but a good cleaning is always good).

For 2, I had been using magnets for the materials I was printing prior to it stalling out, but hadn’t had any magnets on the bed since posting & trying the other ideas. The magnets were on edges of a 4x6" piece of leather, and though I’ve done many jobs of this same material and with same magnet positions & relative bed position (approx. center), it might have been a trigger. But even with no magnets and either just crumbtray or PG med maple ply, it doesn’t get past “focusing” or moving the head out of the back left “home” position.

For 3, the connection is still solid and get a firm click. (And my test of trying to run without the printer cable connected got a glowing red button–so the machine recognizes if the cable is connected or not). And since I was able to run a job after a “jump start” of centering the head manually, it’s unlikely to be a cable issue alone.

Nearly ten minutes now of “focusing” and the periodic ticks… it’s trying, at least. Powering down now.


Hi Jeff, just realized my comment “it’s trying, at least” may have been misinterpreted as it’s running.

No, still stuck on “focusing” even after all the steps you had suggested.

What next? I have now lost two custom job orders…


Thanks for checking on those things!

Next up, can you please:

I’ll be happy to take a look and determine our next steps.

Hi Pip,

Attaching the photo for reference, but now I can give myself dope slaps, and you can close this ticket!

I finally noticed there was one of my small rectangular silver magnets on the silver colored metal support for the head cable (sits just behind & left of the head, and cable clips onto this before it routes into the arm).

So after removing this magnet and restarting my unit, hooray, went from focus very quickly to centering and homing and ready as per normal operation.

I’ll put it down to reducing the ambient light while running and angle of the light before as to why I missed seeing this over the last few days!! And no more setting a magnet on the arm while changing material, which is the only way a magnet could have found its way to this location (I usually stick them to a box beside the unit, but will change that from 95% to 100% of the time!).

Fortunately, this was all squishy organic parts error (i.e. owner/operator error), and not a hardware issue!!

And I’ll paint my magnets a bright color!!

But I did notice that there is some dust & black spots under the lens for the LED? (top lens in my image). I didn’t see anything on the lens on/under the bottom one in my picture. So hoping because the lens on the left/top of the mirror is the light, it’s not a concern…


1 Like

I’m so glad to hear you resolved it!

Regarding minor spots on the particular window

Shouldn’t cause a problem at all. But just to be sure, I briefly checked the logs for some recent activity that could be affected, and everything looked perfect.

I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!