App Not Functioning

My glowforge has a new issue today.

The web interface keeps locking up, not allowing us to move the artwork. It is sometimes black screen, sometimes white, sometimes it is a preview but won’t allow me to move/edit anything. I have tried multiple browsers and computers. Was there an update to the software? What do I need to get burning again??

That is very strange. Did you try loading the Gift of Good Measure design? If it doesn’t misbehave with that one, the problem might be in your file. In which case, if you would upload it here one of us would be glad to take a look at it.

I have tried many files today including those provided by Glowforge all with the same result.

What browser are you using?

If you have an iOS device, you might try the Glowforge app. It’s not as fully functional as the web app but might get you going until Support or someone has a solution for your problem.

1 Like

I tried Safari and Chrome from my Mac and Chrome, Firefox, and IE from my PC.

My machine is functioning perfectly, and the glowforge status page reports all good, so barring a machine anomaly that would suggest a local issue.
You might check your Browser to see it is up to date, and clear your cache.

There have been others who have had this issue so it is not isolated to my network… I have already cleared the cache and tried several browsers and machines.

I’m so sorry you hit a snag. I’m afraid we’ll need more information to investigate further.

If possible, could you please send me a screenshot of what you see in the Glowforge app when you open the Gift of Good Measure design?

Make sure to include the rulers in your screenshot and show as much of the bed as possible

To take a screenshot:

  • Mac: Press Shift-Command-4 and click and drag a box around your image. You’ll find the screenshot file saved on your desktop.

  • Windows: Click on the Start Menu and type “snipping tool”. Open the Snipping Tool > New then click and drag a box around your image. Click the Save icon and name and save your file.

Send us the screenshot, and we’ll be happy to take a look.

I am not sure what the gift of good measure is. I thought you guys were talking about the ruler but I am thinking not now?

Here are some screenshots of both my file and one of the glowforge default files acting up in various ways. In all of these images, I can not move the artwork or zoom/move the artboard around.

Yes, it’s the small keychain ruler. The file is called Gift of Good Measure. They want you to try that because it’s a known quantity, and it will help to narrow down whether the problem is related to your file.

Also, just another random guess: it looks like you have a number of Chrome extensions installed. Do you have any ad blockers or other kinds of things that can affect the content of web pages? Sometimes those can prevent the Glowforge app from loading all of its code and cause it to malfunction in strange ways. I would try turning them off and/or try an Incognito window.

1 Like

The Gift of Good Measure should be 'way down at the bottom of your list of projects in the app window – you might have to click “show more” a few times:

There’s definitely something odd going on – your interface doesn’t have any rulers, for one thing! (But it’s right side up, so there’s that…) @chris1 has a good point re: one of your extensions possibly interfering with the app.

1 Like

Thank you so much for the details. I’m looking into it now. As soon as I have more information I’ll update this thread.

FYI I tried the removal of my browser plugins to no avail.

Thanks for your patience. I extracted the logs from your Glowforge to take a look at the details surrounding this problem, and I believe I know what may be happening here. It appears the files you’re having trouble with were saved using the “Export as…” option in Adobe Illustrator. This can cause some settings to be applied to the file that our software may have trouble handling.

Could you please try these steps?

  1. Open your file in Illustrator.

  2. Without making any other changes, choose File > Save as…

  3. Give the file a name that is slightly different from the original, and click “Save”

  4. When the next dialog box loads, click “OK” without making any changes

  5. Upload the file you just saved to the Glowforge app. In our tests, it took a few minutes for the file to upload successfully

  6. Try a print!

Let us know how it goes.

If you want more detail on why saving as a SVG is better than export as there was a thread way back in PRU days where @chris1 gave a good analysis if I recall, when I had screwy SVG operation.

I’m not exactly unbiased, as I greatly prefer the “export” workflow. But I’ve come around somewhat to Save As (actually, Save a Copy, because I really want to keep working on the .ai file).

The short answer why is simple: Save-as-SVG and Export-as-SVG should do the same thing, but they don’t. It’s like there are two independent pieces of code in Illustrator, with nothing shared between them. The Export-as code is newer and has traditionally had more bugs. Even in the current version, there is at least one situation where it produces the wrong output. In addition to that, the Save-as version includes a special header that says it was produced by Illustrator. The Glowforge software recognizes this and changes its behavior to improve compatibility with these files. The generic SVG produced by Export-as won’t trigger that. Finally, since Glowforge does all their testing on Save-as generated files and only supports this workflow, you’re probably going to have an easier time of it.

I guess that answer wasn’t as short as I hoped.