I had been on a hiatus from using my glowforge for a while and tried to use it again last night. I tried to print something from the forums, as I have done before. I uploaded the design and I forgot to push the button to start the design print. However the app continued to do the countdown and then went through the “cooling down” process like it had actually printed. I then waited a while, and then tried another print from the GF catalog, and then it would not let me click the print button on my app. As well as the button on my glowforge is not lighting up. I canceled that print job last night slept 6 hours, and the job on my glowforge app, that I am trying to run on my computer is still showing as canceling. I can’t use my GF, so what do I do?


You all are amazing! I ended up going to my husband’s home office, and reset up the wifi on the glowforge through the glowforge set up website. I had to hold the button down for about 30 seconds then it turned teal and then finally I connected his computer to the glowforge. This was a huge pain however I am pleased the process is done. I am currently printing as we speak!!

1 Like

Maybe reboot the GF and your computer?
I’ve had that happen before and that always fix it.


I’m confused how the job countdown started if you didn’t push the button. :thinking:
Try clearing the browser cache. If that doesn’t do it, try opening another tab in the browser and prepare a simple file like a cut line and let it go all the way to the button blinking. Then cancel that job and return to the tab where it was stuck. It should be clear now.


I have tried on a new window/ Incognito window/ unplugged, rebooted, cleared history/cache etc. I simply cannot seem to get the print job to cancel. I have no idea on how it started the countdown. I am stuck on what to do. I may try logging on on a different PC??? IDK if that makes a difference…

Which browser are you using?

Having the same issue. Haven’t printed in a number of weeks. There is a print job I am looking at on the dashboard that wasn’t even the last item I printed. Won’t go away. Rebooted, reinstalled app, reconnected wifi. Cancelled print job now stuck.

update: I cleared the computer browser history twice and pulled up on my phone. logged out of that, then logged into the app on computer browser.
It worked! Two days of trying, ugh!

1 Like

I don’t have an app on my phone. I just go to the web browser I’m going to try in another browser I am running on Chrome. When we say reboot the glowforge does this mean turn it off unplug it plug it back in? Also how do I change the wifi on the glowforge? I keep going to the settings page and it just wants me to change my password. Thanks yall.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.