App stuck on "cancelling" for 18 hours

staff
glowforgestaff

#1

I’ve another post up about WiFi connectivity, but in doing some troubleshooting it actually looks like it might be the CloudApp stuck. Is there anyway to refresh it out of “Cancelling.” Apparently the webapp was hung up on without my knowledge as I installed and set up a new router. Now I can’t get the glowforge to connect to wifi as the app is stuck in canceling, and anytime I get the GF through the WiFi setup (teal button etc) it gets all the way through entering the password and hit connect only to get the “glowforge is inaccessible, try again or contact support” message.


#2

Have never ever had any step take more than a couple minutes. With the exception of a very complex engrave that took about 5 min to process. There may be some projects that take longer, some people have reported long waits months ago. My rule is if something hangs for more than a few minutes and I didn’t expect it then just reboot or move on. Most likely the wifi connection has been lost to the GF or computer.


#3

This is easily accomplished. There are a couple of options…

Kill the instance of Chrome that the App is running on, then restart Chrome and go back to the App. You can do this from Windows Task Manager (which you should be able to invoke with a right click on the task bar). But also, if you click the close “X” for a window that’s stuck more than a few times, Windows will pop up a dialog asking if you want to kill the stuck program.

If you can get to the Chrome menu (upper right corner of the Chrome window), look under “More Tools…” and you’ll find “Task Manager”. This is Chrome tasks, not OS tasks. You should be able to kill any individual Chrome window from here.

Also, the “F5” key ought to cause the foremost Chrome window to refresh, which might get you unstuck.

I’m assuming you’re on Windows and not Mac. The same rules apply for Mac but I can’t tell you exactly where to find the tools.


#4

It’s not the browser itself that is stuck, it’s the Cloud instance of the interface, on Glowforge’s end. Despite the printer being off, and even when on isn’t currently connecting to the internet, the “print” page of the glowforge app still says “cancelling,” no matter what machine connects to it.

I’m actually primarily on mac, but I’ve done the equivalent already. I also tried it on Windows, and Mobile. Multiple machines. No luck.


#5

If you click the canceling button, does it pop up the print dialog by any chance?


#6

If you click the canceling button, does it pop up the print dialog by any chance?<

The “cancelling” section of the button is entirely unresponsive. It shows no matter which machine I visit the page from (i’m at work now and have never connected from here before, issue persists)
I just does this, and the button is spinning. Hasn’t changed for the past day and a half. Glowforge is currently off for the past 18 hours at least.

37%20PM


#7

One thing that hasn’t been tried yet…When you get home …open a second tab to app.glowforge.com and if you can get to the dashboard, send something from the catalog to print. WAIT until it finishes processing that design, and then hit the Cancel button on the screen.

That might clear both the current job and the one that’s hung up. Some folks have had success with that method.


#8

Also try selecting your name at the top right of the UI and logging out. Then back in.


#9

i’ve done that multiple times, from multiple machines :frowning:


#10

tried that. I can get to the dashboard just fine, and click on a project, have it render the design and show it in the bed (although the bed image does not refresh obviously) and still nothing. Just “cancelling”

I even get any appropriate file warnings for “we can’t handle text yet” etc.


#11

Well fudge. (All caches cleared and whatnot?)


#12

I know you started another thread but can’t recall what it said. What if you invite a secondary email address, temporarily, to your machine and see what that looks like?


#13

that’s an interesting idea. I already have my wife (the techincal owner per email address) and myself. both show the same thing. but i could add something new.

fwiw i do have access to all computers, at work, have laptop (main machine i’ve been using) and can remote into my Windows machine at home (have never printed from there, but logged into the app). I just dont have access to the :glowforge: itself from here. 1) because it won’t connect to the internet (as being discussed in other thread) and 2) because it’s off (as suggested as one solution to both issues)

It doesn’t even recognize the :glowforge: is offline.

Update 1

I did the opposite as a step one: Had a friend add me to their account, I can see their :glowforge: just fine. Just says “offline,” it is. Just the my printer at home that is bugged at “cancelling”

Update 2
Added a third (new) account to our :glowforge:, issue persists with brand new account.


#14

I had this happen on Sunday afternoon - tried to reset the Glowforge Wifi and was able to connect to the GF wifi network, but connecting to my wifi kept failing. Finally, I powercycled the Glowforge and it connected OK and resolved the issue. I also powercycled my router as well.

App was stuck on Cancelling - I think I might have had a wifi hiccup or something.

Also had an issue later in the day with the app seeing the status of the GF (lid open, etc.) but refusing to update the bed image to the current state (after replacing PG material with a different PG material. Restarting the GF fixed that as well.


#15

Interesting. Glad to hear someone had something similar.

I’d tried the :glowforge: setup multiple times, failed every time right after connecting to wifi. “Glowforge unreachable” error.

This did start when I did change routers. I did power cycle the router again this morning, but didn’t have a chance to try the Glowforge setup again this morning. I’m going to try again when I get home. :crossed_fingers:


#16

Just to clarify…

When I tried the wifi setup on the GF, it never successfully reset the connection. After powercycling it either used the “new” (identical to previous) wifi connection settings or re-used the prior settings to connect successfully. At no time did I get a success message from the setup process while attempting to re-setup the GF wifi.


#17

hrm. yeah my new network is identical in settings to my old. still no success. the :glowforge: is literally the only device that hasn’t just accepted the new network and started working. including others that require 2.4 connection.

fwiw I used the old router and it got it through stuck on “cancelling” after the Staff reset whatever they did on their end. still isn’t connecting.


#18

Thanks for reaching out. I’m so sorry your Glowforge was stuck.

Since this has been resolved, we’ll close this now and continue working with you in the other topic.


#19