Auto CAD DXF converted to SVG(or a cutting file)

I have an issue with the scaling of my designs made in auto cad 2017 imported into app.glowforge.com . I have been able to cut this product by convert my DXF Files from Auto Cad to an SVG File type using Convertio.com. When I import he project, the files imports a different size. Why is this?

My question is what would allow me to draw to size in Auto Cad and export or convert in to a cutting file? Then when I open up the file the size of the parts dont change?

What have all of you done?

Please help my students are in need!

If you search the forum using the search term “scale” or “scaling” you will find several posts about this using various programs.

HTH

This is almost always caused by improper settings during conversion, esp. resolution (DPI), and the evil ‘responsive’ tag set to true. As suggested above, there’s been a great deal of discussion on this topic:

https://community.glowforge.com/search?q=DXF%20scale

1 Like

I think MeshMixer will take DXF in and output SVG. I’m pretty sure it’s still free. And it’s now owned by Autodesk so the odds are it’ll have good compatibility with DXF.

I’m sorry that you ran into trouble when trying to convert your DXF files to SVG. I would recommend looking into Inkscape. Inkscape is an open-source graphics editor available for free online.

You can find some first-steps on how to install the software and where to look for tutorials on our support page. Here is a link to the topic: Introducing Inkscape

Inkscape has the ability to import DXF files and then you can manually set the scale factor. I hope this information helps you and your students to get up and printing with your designs! Please let me know how it goes.

Just save them to PDF right out of AutoCAD. They are saved as a vector format and you can import them right into GFUI. I do this with my CAD software and there is another user who has found this works great and has solved some of his issues also.

You may have to set up your PDF export settings to ensure they don’t scale to fit the sheet, but it should only need to be done once.

1 Like

First you have to make sure the AutoCAD file has units defined since a new blank drawing has no units by default. Then other programs will be able to read the scaling in the DXF file.

I use Inkscape (Open Source) to open DXF’s that I’ve exported from Fusion 360.

In Fusion I set the file units to millimeters then in Inkscape I use a manual scale factor of 1, because the default in Inkscape is also millimeters.

2 Likes

Try saving your DXF as a PDF from your creation program. I suspect you will avoid the need for the intermediate steps unless you are using them to add additional material.

Nope, the only way Fusion will create a PDF file is if you set up drawing views of a 3D model first. It’s not difficult to do but often I won’t even make a 3D model, and just work off 2D parametric sketches. Cant make a drawing view, and thus no PDF option, from 2D sketches.

If operation steps need to be altered it still needs to go into another program for that because Fusion doesnt differentiate linetypes, colors, etc.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.