Autofocus suddenly stopped working on 3 machines

We’ve got three machines and have been engraving the same products for years. Suddenly, as of yesterday, none of them will autofocus on a product that is .36" (1.76" total) above the level of the chrome tray.

This is, obviously, too coincidental to be all three machines failing at once (they work on our other product heights) and so the only thing I can figure is that there has been a software update of some kind that is causing this.

It would help greatly to know we are not alone in this struggle. Thanks in advance!

Look for anything else that changed. Is there a light in the room that was not there before? Are you using Set Focus?

1 Like

Nothing else has changed with regards to lighting, temperature, etc.

And, yes, though we’ve never had to use set focus before (auto always worked) we have tried that to no avail as well.

I don’t think it would help a bit to know you are not alone in the struggle. You want it fixed.

I assume you have already contacted Glowforge support. While waiting for their reply, I can only share with you that I have not experienced this problem. As stated above, has the lighting changed? Can you try a different browser? Can you try a different material (maybe Proofgrade) and see if the result remains the same?

1 Like

It would help to know that there is something affecting all users across the board, like a software update, that can potentially be reversed on Glowforge’s end.

Different browser is not something we have tried. I’m not sure how that would affect Glowforge’s ability to focus on this particular product but will try anything at this point.

Different materials are irrelevant as it works on other products at lower heights. To reiterate, we have engraved hundreds of these without issue and then, suddenly, none of our three machines can find them.

Does Glowforge keep a log of software updates anywhere? Would be helpful to know if there was one that times up with when we started experiencing this issue…

I just got my machine back working having discovered it was the Internet provider that made the change that caused the problem.


That has happened, but when it does they hear from thousands of folks about the issue. And very quickly fix it.

1 Like

Interesting that your internet provider was the culprit… we’ve got 20 other products engraving just fine so I’m not sure how a change by the provider would affect just the tallest product. Will check with them regardless…

My machine just applied an update (you can always tell when the power cycles before any focusing, it’s the first thing the OS checks for). Best I could come up with was two pieces of 5/32nd Purebond (measured just about 0.317") and “Set Focus” measured them just fine.

Thanks for running the test. This product is a very dark material. We have been able to jury rig it by putting a piece of masking tape on it and setting the focus on that masking tape. And that has worked… A temporary fix, but the issue appears specifically related to tall, dark materials.

You mentioned that room lighting hasn’t changed but perhaps the lighting IN the glowforge may have dimmed? Perhaps place a lamp near the machines and see if you can lighten things up internally while it’s trying to focus?

1 Like

All three machines didn’t dim at once (one is even a brand new replacement) but I will try adding some light as you’ve suggested!

yeah it’s definitely unlikely. But I never rule anything out until I’ve ruled it out. :rofl:

1 Like

Then that is the issue! Using a standard white masking should fix the problem. The Set Focus measures with a common red laser and if the camera that does the looking cannot see it (well enough)any focus will fail. You might try cleaning those windows on either side of the main focus lens. If you are doing a lot of work between using the dark material a bit of fog there might add to the problem enough to kick it over on several machines at the same time.


I switched out the top sheet for some THD B&W board (glossy whiteboard on one side, black chalkboard on the other.) Combined 0.335". Black side up.

It took a noticeable few seconds longer. I rarely pay attention because my GF is on the other side of the house, and I’ve only ever engraved/cut on the white side.

1 Like

UPDATE: put a very bright work light over the machine. It did not fix the issue.

If it’s a dark surface you need to make it lighter (not by shining a bright light into the machine) so the machine can see the red laser. Use a piece of masking on it where you plan on focusing. If the red dot hits that it should be able to measure the thickness.


I also have Two machines and complain about changes being made to the Glowforge that effect both machines. Most People think it something dumb like new light bulbs , lol I have an office setup that has been the same since I got my first glowforge. I know when both machines act the same way as i run them on two different internet companies . This way i have insight at to what is really happening. Given that you mention all 3 machines have changed, it means that there was a change made on the software. I cut 0.5 material only and I know when they screw with the settings and I have to change mine. If you could post Dates and Times as I do, we can sync the changes . I aslo was told about black , but that was nonsense , Everything we cut is black. One thing I did come to grips with was that the material i was getting was not always the same height and the glowforge had no tolerance for it, sadly. Thus I do have to throw a lot of material away that is not exactly 0.5 as any amount of over that is a No Go. I now use just a little stick glue to help it adhere to the deck but the problem with that is the fan gets glued over time , so yeah there is that. Lets see if we can figure it out .