Best browser for Glowforge app?

Im new to Glowforge (not to lasers) and I am having a bit of trouble getting my first personal project going. I am using safari on a M1 iMac to access the app and load my files but I am running into so many frustrating issues that the experience with with app/online is giving me major buyers remorse :smiling_face_with_tear: I did not plan to spend the rest of my night frustrated and on the verge of tears.

What is the best browser to access and design within the app? Im not sure if my browser is causing the issues. But I just lost everything I had done in my file (adding multiple designs to cut at once) I went to make a change and the entire page refreshed and reverted my design back to only having the first file. The app is extremely slow loading changes and often times it was showing my files wonky or pieces of it were missing until I messed with the scale. Like the color for the score/cut/engrave were not showing up despite making the changes. Im assuming some browser work better than others as far as compatibility goes.

Chrome is recommended.


Thank you I will try using that and see if its better.

While Chrome is probably the most supported, if that means anything at this point, Safari should work fine. There have sometimes been glitches, but they get fixed, because Glowforge officially supports Chrome, Firefox, Safari, and Edge. I have been using Safari with my Glowforge for years.

That’s all the long way of me saying I think the issues you described are way beyond anything caused by using the “wrong” browser. My guess is that you have problems with either your network connection or your computer. Everything you do with the app is sent up to the Glowforge servers and should be in sync within a few seconds, so losing a huge chunk of work like that means your computer was not communicating with the server for an extended period of time. You also mentioned slow loading and not showing files correctly. That M1 Mac should be extremely zippy, so something must be interfering with things loading properly.

Changing to a different browser might help, since that could eliminate weird plugins, add-blockers, cache issues, etc.


The first thing I assumed was to check my internet connection (which was fine). The test project I did I did on my older iMac using firefox worked fine but on the M1 which I primarily use to design files I literally only have safari so that’s what I used this time. Im also using SVGs so I dont know if that may also have play in the results im getting.

I noticed when I would add the file it would show up (all red and the artwork had dashed lines) I would change the material and then go through each layer and set it to cut/score/engrave. The red lines would not change or update and then editing the actual artwork to make changes would result in these weird red shaded areas and half the file looking weird. I closed the file and tried again different results, then once I resized it it was fine, the lines the app uses to differentiate each cut showed up. This would happen with the 5 files I uploaded off and on.

I’m lead to believe its a browser/file issue because of the random behavior it wasn’t like one consistent error and when I went into edit the file I clicked on a single shape directly and the page literally tried to load another page and reverted my work back to having the one file I uploaded.

I did eventually finish my piece


It’s a very nice design.

I was just throwing out random guesses. I know Safari works, but I don’t know why it’s not working for you. It could be a million things, but if switching browsers helps, it’s probably a moot point.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.