Blank bed image

This happens to me occasionally (I use Chrome), but usually clears if I exit back to the home page and come back again.

I have not experienced too many issues with the GFUI until recently. Some similar to yours.

Here’s a list I’ve been compiling:

  1. previously uploaded files losing the artwork. Someone suggested I had deleted the artwork. I accepted that on the first one, but it has happened 3 times now on 3 different files. It could still be me, given the old age, but I am having my doubts.
  2. Set a cut operation for a file along with some engraving. The tiles on the left show the settings. Ran it and only the engraving completed. There was no cutting. Set engraving to Ignore and re-ran okay.
  3. Six “Unexpected Error” messages when attempting to load a previously uploaded file.
  4. “Offline” message after completing a run. Tried turning off/on laser, verified network was working.

I was thinking maybe had something to do with the latest release. Expect for having to reload the artwork, most of the time I can get things working again by either closing down Chrome and re-opening or doing a restart.

Or it might have something to do with the last Windows update I got last weekend…

When I get the white it disappears as soon as I select a material…


Some of the Google and Amazon services have gone down over the last few hours. I would try waiting a little bit until everything is back online. Check for chrome and flash updates? I know that the GFUI does not use flash but it has affected loading for me for some reason.

You can check the statuses of Google and Amazon servers at the following locations respectively.

Google Appstatus
Amazon Appstatus

I don’t think they use AWS for anything (but may be wrong).

For google services, I like this link:

Glowforge also has a status page at but I’m not sure if it updates real-time, with a lag (or how much lag), or manual updates.


It happened to me some time ago. I resized the Chrome window and the bed image showed up.

Thanks for letting us know about this. In addition to the suggestions above to try a different browser or restart, there is another possibility I’d like to check out.

Chrome updated to version 73.0.3683 on 3/12/19. Even if automatic updates are turned on, you may need to restart the Chrome browser in order to apply the update. You can click on “About Google Chrome” in the browser menu to make sure.

Could you please let me know if you’re using the current version, and if not, if updating helps resolve this issue?

1 Like

I have version 72.0.3626.121

Looks like there is and update that wasn’t showing where it normally does. Currently updating.

Thanks for checking that out. It’s also a good idea to clear your cookies for *, if you haven’t already tried that.

Let me know how it goes.

Thanks! It’s one of the first things I did. But it’s been working for the past few hours. Mystery glitch is gone. :man_shrugging:


@vee could the bed image also be related to the Google Drive error/outage Google was experiencing yesterday?

@JeremyNielsen I see you had memory intensive programs open and well as multiple tabs. A possible shortage of processing power?

1 Like

Yeah, I thought of that too. I rebooted my computer and just open up Chrome but still ran into the issues

1 Like

Well my confident computer expertise stops at “Have you tried turning it off and then back on again” and “close all the things” :rofl:

Other than those, I just blunder around until I think I fixed something on my own system.


I’m so sorry for the delay. To clarify, you aren’t experiencing this issue anymore?

Looks like it’s fixed but just to add one more thing, since it looks like you have a lot of extensions and customizations in your browser… sometimes my ad blocker will decide to break the Glowforge interface, so I make sure to whitelist it.


It happens from time to time. Usually a refresh of the browser fixes it but that day it was specifically not wanting to go back to normal. I’ve only seen it once or twice since.

I’m experiencing the same issue, blank screen or partially loaded file that is not selectable or moveable. I’ve tried all of the above (reboots of all machines and router/refreshes/clearing caches&cookies,etc.).

Of note however, the note above about Chrome being at 73.0.3626.121… On my Mac, under “about Chrome,” it states I have version 67.0.3396.87 AND that it is “up to date.” (Perhaps it’s a Mac vs PC version?) I did not have any problems only a couple of weeks ago. So the Chrome update would make sense, except that my computer thinks it’s up to date.

:frowning: So sad. Can’t create. Do I need to create another thread and/or contact support directly myself? Or is it something that I can piggy back here? Was hoping I’d find the solution without having to get staff involved.

Appreciate the help from staff and the community here at any rate.

They will only address one person’s issue per thread, so you’d need to open your own to get staff support. (Opening a thread in P&S creates a support ticket, so don’t duplicate by also sending them email; that just slows things down.)


Thanks for following up, @JeremyNielsen. I’m going to close this thread, but we’ll keep digging into this on our end. In the meantime, if you encounter this problem again please start a new thread or email us at

@n_dawson I’m sorry to hear you ran into trouble as well. We try to limit support threads to one issue and user per topic. If you start your own thread, it will create a support ticket, and we’ll be happy to help.

1 Like