Blank screen

So today i have a list of work for the Glowforge and all of the sudden the app decided to go white screen on me anytime i click on a shape to cut… I have work to get done and this thing isn’t working any help ASAP would be greatly appreciated.

You’ve opened a support ticket by posting here. You can save time by pasting the link you get from, so they will have that information when they check in here.

It appears to be popping up for a number of users today, so hopefully they will spot that and can get it resolved quickly.

I did check your link and it states that my browser is up to date and also stated yes to all the options below. I hope they fix this issue fast. I pay for premium accounts because I run a business with my laser and I have a lot of work to get going. I will have to see if I can make the file externally and import it hopefully that resolves the issue for me but its not really an acceptable fix to the issue at hand.


It is also doing this to me today, with shapes, text etc. Frustrating.

Happening to me too! Whenever I try to add an outline to an image.

Posting “me too” in other owners threads will not raise the priority with GF support. The ticket will just sit in the queue until they get to it.

Opening your own discussion with the same issue (or sending an email) WILL get their attention, when multiple tickets have suddenly been opened with similar titles.

1 Like

I’m so sorry for the trouble! The team is looking into this now and I’ll follow up as soon as we have an update.

I’m eagerly watching for the update to this as well…my interface started doing this last night as well.
I can still cut/engrave just fine, but the second I try to do any shapes/text (or even clicking on one of those that I do have to mark ignore on it), the dreaded white screen opens up and stays…have to relaunch the UI to get back into it.
I’m not sure if it will help at all, but this is the link that is in my window when that screen opens:

I clicked on that link, and it took me back to my opened UI with design, but when I click on the square, it opens the white screen again…

@dave.martin2008 @amykaway @sierramay84 @a.osterman86 could you try again and let me know if you’re still experiencing difficulties?

It is working for me now. Thank you!

1 Like

yes its working on my end as well thank you

Thank you to everyone for bringing this to our attention, and for your patience while we worked to resolve it. All issues should now be resolved. Should any additional issues arise, please feel free to start a new Problems and Support post, or email us at Happy printing!