Calibrating Hell again, diagnosed: warranty return

My topic was closed EUR, Pro, also stuck on calibrating. What did suppot do for you? but the idea behind that thread was not to open a ticket (as I had already email contact them) It was to write down what was happening with the machine and service to international costumers as to have a written account for other users.

So 5 hours after my last email to support I got an email explaining to me that Glowforge had sent an update to my machine and that I needed to install this. (lid open, power on, wait a few minutes, reboot, close lid and voila) And after this the machine came back to life again. I did a test job on it as it was already late in the evening for me and everything worked fine. Great!

but this morning I turned it back on again and nothing. No movement. Just the regular sounds from the pump and the loud humming of the machine. Nothing moves. Tried power cycling, calibration, I tried the lid open power on thing again, calibration. I’m trying to figure out what’s going on with my machine. I’ve emailed support and I’m asking an explanation again too. I’d like to let users know what’s going on. Try to understand it and pass on the knowledge to my Dutch glowforge group.


This sounds like it might be no WiFi. Try rebooting your router. If that fails you might want to go through the entire WiFi setup process just to be sure.


I’m willing to try it all. Reset all the modems and routers in the house. Turned Glowforge back on. And it’s back alive again! Thank you Evansd2 for the tip.

Now instead of support closing this thread again keep it open and maybe even let us know why the calibration issue keeps popping up.

1 Like

In this case it sounds like the cause was that your router and the GF couldn’t negotiate a DHCP lease. Lots of routers get hung up on DHCP negotiation and periodically need rebooting — this looks to me like it wasn’t the GF’s fault.


All threads in Support will get closed—that’s how they work, because a posting in this category generates a support ticket. That’s why you should not both email support and post here for the same issue. If you want the thread to continue, you will have to change the category to Everything Else or maybe Beyond The Manual.



but this also lessens the chance someone from the inside will explain to us what exactly generates the error.

That’s because different things can generate the error, and in each case, only the support team at Glowforge has the information necessary to diagnose the issue. So if it happens, the customer pretty much has to open a support ticket so they can take a look at it.

Usually, if it gets stuck in calibration for a long time, that’s a sign of a sketchy Wifi signal, but not always. They can look at the metrics for each individual machine and tell folks what to do to fix it or continue the testing.

So the thing to tell your Glowforge group is that if they do have a problem, they should notify Glowforge immediately, and to provide as much pertinent information as they can up front. That includes the date, time and time zone of when the problem occurred, so that support can look up the metrics for that machine. The steps you have taken to try to get the machine working or further test the issue also help. It helps to include a zipped copy of problem files if it is just one file that has the issue. And photographs and short videos of problem behavior can help in certain instances. Just give them whatever you have that you think might help them to diagnose the problem. What adds so much time to the resolution is the waiting for the back and forth communication.

1 Like

After the succes of resetting routers and modems yesterday I powered on the machine and again no movement. I’m not sure which is more frustrating, the fact that the glowforge only works sometimes or that no explanations are given by support for the errors.

To summarize:

- June 30th, I sent my first email to support. I tried powercycling, moving the head manually and turning it on. The machine had been working great before this. I changed nothing, I moved nothing I just operated it like usual.

- June 30th, I receive a reply from support. They extracted logs, looks like wifi’s acting up. Support suggests I reset modems and routers, devices that communicate with the glowforge and of course the machine itself. Also they ask me to extract some logs from my machine too straight through wifi pairing. After doing so I snoop around in those logs to see what I can figure out myself.

Logs look like this:
2018-06-30_21:00:59.75509 59680 DEBUG: mhs_laser: setting to 0
2018-06-30_21:00:59.75509 59681 INFO: camera_peripheral: Waiting for image…
2018-06-30_21:01:01.31053 61242 ERROR: hw: Coolant flow failure (broken pump) (src/hw_task_messages.cpp:112)
2018-06-30_21:01:01.32391 61247 INFO: hw: error flag set: fault:coolant_flow_fault:set (45)
2018-06-30_21:01:01.32396 61252 INFO: coolant_flow_controller_peripheral: Entering pump state 1
2018-06-30_21:01:01.32398 61252 INFO: coolant_flow_controller_peripheral: Pump on
2018-06-30_21:01:03.25816 63189 ERROR: camera_peripheral: failed to receive image after 3507 ms. (11: Resource temporarily unavailable, src/cam_manager.cpp:286)
2018-06-30_21:01:03.27140 63197 DEBUG: white_led: setting to 0
2018-06-30_21:01:03.27144 63199 DEBUG: uv_led: setting to 0
2018-06-30_21:01:03.27145 63201 DEBUG: mhs_laser: setting to 0

The only errors I could find accounted to either the coolant pump or the lid camera not responding. I looked over the pump area and saw nothing out of the ordinary. Checked all the connections and I did the same for the lid camera connections. All the ribboncables I could find. Checked their connections and tried again. The machine came to life! Awesome. Did a test cut, everything worked fine. Turned off the machine to go do something else and I returned later to find the machine stuck in calibration again.

On juli 2nd I sent a followup email to support because I had not gotten a reply yet and to tell them what had happend in the meantime. (Got it to work, finish a job, stuck in calibration again, got it to work, did a test, stuck in calibration again)

Later that day I received an email from support that they were going to push an update (I guess firmware) to my machine that should resolve everything. I was disappointed that there was no info on the errors in the mail but excited that I could work my machine again. After the update (lid open, reboot etc) The machine booted like normal and I was able to go through another testjob. Everything was awesome again. Except I still didn’t understand what is going on with my machine. I want to know what error it was/is that keeps it stuck in calibration. So I shot another mail at support asking for an explanation

juli 3rd I powered on the machine in the morning to rush a job through that needed to be sent out of the country, but nothing again. Calibration, calibration, calibration… nothing. Of course I was mad and I tried all the tricks I had learned again. Powercycling, manually moving the head, resetting all devices, check all the cables. I even downloaded new logs but since nobody cared to explain to me what to look for in the logs I could only find the same errors (Lid camera and coolant pump). I emailed support again.

juli 4th, 5 hours ago I received my last email. Pretty much the most American email I’ve ever gotten not really including any relevant info on the problem and the dreaded:

"Unfortunately, we’ve found that your unit has a problem that we can’t solve remotely. While it’s possible that this could get better, it’s unlikely to be resolved without replacing the unit. I don’t want you to find yourself polishing off an important print and having this issue arise at the last minute, so I recommend that we make a warranty replacement. "

Now I’m glad the company will replace my machine with a new one and ship it both ways accross the globe under warranty. But I’m very disappointed that nobody at support has made any effort to explain the root of my problem. Is it software or hardware? Is it something I can try to avoid in the future? Is it a known bug? I’m guessing I’ll never be informed as to what happend and with that it takes away a little of the joy of owning a glowforge. As the question arises every time I turn it on. Will it calibrate?

1 Like

I reread the latest logs. These are the two errors that keep popping up:
2018-07-04_08:25:57.08381 85269 ERROR: cam: pipeline returned a null frame (src/cam_task.cpp:343)
2018-07-04_08:25:59.08515 87280 ERROR: cam: gstreamer: Internal data flow error.

You mean “an email from tech support on the largest national holiday where only the most dedicated US-based employees who really care about your problem would take the time to help me”, I’m sure.

I’m surprised that anyone was available to help you, and quite impressed by it. I understand that you’re frustrated but GF doesn’t owe you an explanation, they owe you a working unit, and they’re doing what’s necessary to get it to you on a huge holiday where pretty much anyone in a non essential and/or service job stops working.

Gold star for GF support.


SO MUCH THIS! Thank you for saying what I was about to, but in probably a much more considerate way. :eagle::us:

I totally get the mass frustration, and just wondering what in the heck is going on, but like evansd2 said, Glowforge doesn’t HAVE to explain what is happening, that could all be proprietary info, just be happy they’re sending a new machine, and covering the shipping.

Now, where did I put my barbecue tongs and fireworks… :sparkler::fireworks:


From the logs it appears you have an intermittent spike in the pipeline figulator circuit likely caused by an RF filter operating at the extreme edges of specified operational tolerances as a result of inadequate clearance on the 14um silicon layer in the IC control head.

Feel better?





Yeah, I know I’m not supposed to laugh at this, but… in the most lighthearted way… :smile:.


If it were my figulator on the fritz I’d be grumpy for sure.


If that last email would’ve come on juli 5th I would not be bothered. Not everyone is from the US but I do care about holiday time off. My intent was not to complain about the times the support department operates although it is a hassle for me that there is no European time-zone support department. There is a 9 hour difference with my time.

Glowforge does not have to explain anything, but it would be great to know what’s going on and why the machine stopped working. If your car stopped working and the dealer would get you a new one, wouldn’t you want to know what was wrong with it? Maybe it was how I treated it, maybe it’s something you can lookout for in the machine as you are getting the same car with possibly the same faults.


I’m totally with you on the “nice to have” aspect.

I can’t say why GF is so tight lipped about details, my guess is that it’s a mix is stuff like liability concerns, trade secrets, publicity and who knows what else. Cold comfort when all you want is a working laser, and would like to try to solve the issue without shipping it back.

I hope you get resolved soon, once your machine is reliable it’s a great tool.


Want to know why they will never tell us?

Because it’s dangerous to try to open up a laser and fix it yourself. People can seriously hurt themselves trying it.

And if they post information on what the specific issue is on a public forum, someone is going to read about it, think he’s got the same problem and knows enough about the way the laser is put together to dive in and tackle it himself and wind up getting hurt or breaking the machine.

So they will never tell us. Might as well get used to the idea. It makes life a little less stressful. :wink:


What she said, which I lumped under “liability concerns” :wink:


Juli 10th, still no communication from Glowforge. Waiting for shipping labels to return the machine.

11 day after first break down, 5 days after warranty return confirmation.