Calibrating Indefinitely

I bought the GF pro to use in an educational setting (High School), and as of today it’s been “calibrating” for nearly 3 hours. I’ve tried re-booting, I’ve tried redoing the setup procedures, nothing is working. Classes start in two weeks - all the curriculum I’ve developed for the students will be a waste when the laser is calibrating for their entire class period. Please help.

One thing to try while waiting for staff to respond –

Turn the machine off, open the lid, then turn it back on, and let it sit for a while before closing the lid and trying again. Sometimes the calibration is fighting with a software update that’s trying to download, and opening the lid gives it a chance to download by preventing calibration from starting right away.

4 Likes

What is it doing exactly?

Is it just sitting there?

Is it moving around at all?

Is the white light flashing at all?

1 Like

So far it hasn’t done much of anything. The very first time I turned it on, the head moved around a little bit. Other than that - no lights, no movement, nothing.

Thank you for the tip, I’m trying this now.

You might also try cleaning the lid camera and the lid of the laser head where the Glowforge logo is.

Are you getting status updates in the UI, like lid open? An updated bed image?

I don’t think cleaning is the answer here. From what I read, it’s not moving at all anymore on power-on. So it’s not even trying to “actually” calibrate yet. If it was moving around and trying to find its mark, I’d definitely agree though. :slight_smile:

1 Like

It’s a 5-second procedure that is good practice anyways.

I am getting status updates i.e. ‘lid open’, ‘offline’. However, the bed image has not updated.

1 Like

A working unit takes 90 seconds or less to calibrate when you turn it on. Once per power cycle. Sounds like the unit is confused.

1 Like

The unit and the owner are both confused. Maybe I should have the unit stay after class for remedial education. Or move it to the front of the room so it can see the board better…

9 Likes

Just to be clear, has this unit ever worked or is this the 1st attempt?

Having experienced exactly what you are, more than once, I can say with some absurdness that it’s likely WiFi-related. A couple of suggestions in no particular order:

  • With the 'forge off, gently move the head to directly under the camera, close the lid, power on
  • Move your 'forge and router closer to each other (not fun, but I found it to work with a unit I ultimately returned)
  • Change WiFi channels (fast, easy test… doesn’t even require you to reboot your 'forge. Try channels 1, 6, or 11. If you’re already on one of those, try another.)
  • Try connecting your 'forge to your phone’s hotspot

Good luck!

Just to add to this, a working unit might re-calibrate randomly if your internet is a little spotty – it’s not the unit being spastic, it’s the wifi connection. That’s probably not the reason OP is having issues, but just for anyone else who gets a random re-calibration in the middle of a power cycle – your glowforge might be working totally fine, but your internet might not :slight_smile:

3 Likes

The unit has worked just fine on several occasions, in the exact spot in relation to the router, same setup, same everything.
I cycled the power one more time. I did notice that it makes a few ticking noises like it’s trying to move, then I get one white flash on the button. What does that mean?

The ticking is the lens calibration.

The white light means it has at least received some kind of instruction from the cloud. That you are getting status changes in the UI is also a positive indicator that it has a WiFi connection.

1 Like

If the ticking noises are what I suspect they are, that’s not a movement attempt. Totally normal sound. Kind of a tick-tick-tick-tick-tick… pause… tick-tick-tick-tick-tick? Yeah, that’s normal. A single white light is also typical and expected behavior when it makes a WiFi connection. But that doesn’t mean the connection is “a good one.”

I hear ya. I’ve had mine working just the same for over a year. And then it did the exact same thing you’re describing. You probably haven’t scanned WiFi for any changes you CAN’T see. Like somebody else broadcasting on the same channel and causing interference. That’s why I suggested the specific things I’ve suggested. Try 'em. What can it hurt.

2 Likes

So, I moved the head to directly under the camera, moved the GF to within 10 feet of the router, tried a few different channels, and connected to my phone’s hotspot, all with the same results…
P.s. Thank you for your help, I’m pretty lost without you nice people willing to lend a hand.

1 Like

Wow. You did all that and it still won’t calibrate?! I’m out of ideas. I’m afraid you’re waiting for Support to look at logs at this point.

I appreciate your help. I’m just hoping I can get this squared away before school starts and I have to explain to the school board why this huge purchase we made is just sitting in the corner collecting dust.

1 Like

I didn’t comment on this one earlier because I wasn’t sure the situations were the same…do you have to have a certain password or permission to access the WiFi in a school situation? It might be more complex than the normal WiFi issues, and support might need to take a look at it. :neutral_face:

When the button flashes white - data is being sent to Glowforge…that’s a good thing. If it does the little click-click-click when you turn it on, that is also a good thing, it means the stepper motors are calibrating like they are supposed to at startup. ( You’ll also hear a few clicks after the cooling off period and see a flash of the button. Then you can open the machine and take out your print.)

If there is an update being applied at the start, it’s best to let it finish without turning the machine off, or sending orders to it, and if you do that while it’s updating, the communication with the mother ship can get hung up. Or sketchy WiFi can cause problems.

In the future, get into the habit of turning the machine on first by powering it up, then leave it alone until it finishes calibrating, before you open the app. Do it a few minutes early and let it finish updating if it needs to.

For now you can try this…log out of the app. Turn off the machine for a minute or so. Open the lid and turn the machine on, with the lid up. (Lets it update without further confusing input I think.)

After a few minutes, close the lid and see if the machine begins the startup calibration. (Click-click-click - and the head moves to the center then back.) Once the head moves back to the upper left corner, it should be ready. Then you can open the app and should be able to get going with it. It might take up to fifteen minutes to get through all of these steps - just give it time.

If it’s still stuck in Calibration though, it might be something they have to look at.