Calibrating, Offline and Purple light!

Hi there,

Yesterday no problem, today, turn the GF on and it says Calibrating and goes to Offline, goes back to Calibrating and goes to Offline again until stays Offline and Purple Light on GF.

Any clue!?



Up until the purple light, I was guessing either intermittent Wi-Fi connectivity or too high ambient air temperature. When you said purple button though my guess changes to power problems assuming you didn’t press the button accidentally when you leaned over to hit the power switch.

Hi Markwal,

Just switch it on and that’s it… Calibrating 4 or 5 times with the ticking noise and then Offline and Purple Light!

No leaning and or anything else!

After running the setup again, that shows up! :confused:

I got the same message last week. Nothing I tried worked, and believe me I tried everything. Only thing that “worked” was to leave it off for a few hours. Magically it started working again.

As I have no other option, I will do that as well!

Many thanks for your message anyway! Really appreciate!

Thanks for letting us know about this, and I’m sorry you ran into trouble. I extracted the logs from your Glowforge in order to investigate your report, and I can see that the your unit has been rebooted numerous times in short succession this morning. The Glowforge may not have had time to calibrate properly before being rebooted. I’d like to have you try a few steps so I can research further.

Could you please do the following?

  1. Exit the web browser you are using.
  2. Turn off your Glowforge.
  3. Wait at least 10 seconds.
  4. Turn on your Glowforge (please do not touch the button on top of the Glowforge - only the switch on the back).
  5. Once the Glowforge is on, please wait about three minutes, or until all motion has stopped for thirty seconds (whichever comes first).
  6. Open your web browser and navigate to
  7. Reply and let me know the following:
  • If the status of your Glowforge in the App is “Calibrating”, “Offline”, or something else.
  • If the button on top of your Glowforge is glowing with any color other than white.

Thank you in advance.


I did all that and the result is the same… before, I’ve tried also with a different browser and the situation is this:

The light is Purple as per photo attached.
And there is no movements of the laser head on the “Calibrating” process…

It switches on, makes the noises (no movements) wait and the light goes Purple/Pink and the status is Offline.

I’m leaving the GF on for a bit more time to see if does anything.

If it does I will let you know!

Many thanks,


vee, any news ? :frowning:

Hi vee, did you have a look into it ?

What should I do ?

Can you help ?


Thank you for your patience. I followed up via email with some next steps I’d like you to take.

I did try to do that but nothing happens when I go to the link to download the log file!
Will try it again now…

SORRY! Had to make the video really low res to be able to upload here!

Thanks again for your patience while we looked into this. I’ve made a small change on our end that should clear this up. Could you please do the following for me so that the change can be applied?

  1. Turn off your Glowforge.
  2. Open the lid of your Glowforge.
  3. Wait at least 10 seconds.
  4. With the lid still open, turn on your Glowforge (please do not touch the button on top of the Glowforge - only the switch on the back).
  5. Once the Glowforge is on, wait around two minutes, keeping the lid open, so it can download and apply the necessary updates.
  6. When the update is complete, your unit should reboot on its own. When this happens, go ahead and close the lid.
  7. Your Glowforge should proceed to connect and calibrate, then you’re ready to print!

If at any point during these steps, the button on top of your Glowforge glows with any color other than white, or if you run into any other trouble, please stop and let us know.


1 Like

Hi Vee, doing it right now!

Will keep you updated!


Rodrigo Felix


Hi Vee!

Thank you so much!

Printing right now!

Can’t thank you enough.

Looks like my weekend is sorted now!

Have an amazing one you !

Rodrigo Felix


I’m confused… Are you saying that the unit only downloads updates when the lid’s open?

1 Like

That’s great to hear! Thank you for getting back to me so quickly, and again I’m so sorry for the trouble. Happy printing!

1 Like