Calibration Issues

For those of you who have had your units for a while-- how often does it tend to request calibration? I got my unit today and upon first attempt to set it up it made some thumping (as if the belt was slipping on the arm, the belt would be moving without the arm going anywhere). Didn’t let it do that too many times (the noise felt very wrong). Powered it down and unplugged, tried moving the head to center and then it worked. Burned several projects all afternoon. However, it does seem to like to request calibration a lot, then more or less freeze on the “calibrating the head of your Glowforge” phase forever* Have tried powering down and unplugging for a while this last time, with no luck. It seems to be really frozen this time.

*forever in this case being any more than 30 minutes, which is I think a respectable enough amount of time to feel certain it has failed.

I see that you are also having a GlowForge fun day. I swing between loving and hating this thing. The hardware appears to be very good. Unfortunately its a mute point if the software and the cloud sucks big time. For the last several days mine does not want to play. Today was the worst and I was about to put my Pro up for sale it was that bad. Overtime I bitch a little most folks tell me I should have waited until the GF was out of Beta. After two years waiting that was not going to happen.

My biggest beef is that the software is not even Alpha it is that unreliable and minimal to boot. I hope that in the near future that the folks at GF figure it out and provide API’s so that people who know what they are doing can write a local network application and get away from this cloud garbage.

I have been trying to repeat cuts from files that I had cut on my friends FSL laser. Example… One file that took 12 minutes on the FSL took me over 70 minutes yesterday due to the GF either being offline or calibrating and the file scan hanging up. Not to mention that the bed image keeps going away when I add another graphic and is taking minutes to update. Last week everything was going well. This week, I hate this machine and have began loathing the GF folks for their inability to improve things.

Oh another thing I found out today. I had a blind open with a little sunshine hitting the GF. After its hundredth calibration the head kept slamming into the front frame at the pass through door even though I always center the head when turning on. Closing the blind resolved that so it did its normal calibration… repeat… etc. I guess the bright light was hitting the lens on the left side of the head.

What the Hell is going on? And good luck with your new toy. You will need it.


The thumping can happen once in a while - generally if the head has been moved manually from the starting position in the upper left hand corner.

If you let the machine move to the correct position after cuts, it finds home all on it’s own. If you move the head for cleaning while the machine is off, or when removing material, it’s going to thump. The startup routine expects it to be in a certain place, and if it’s close to that place but a little too far left…that’s when the stepper motor thumping happens.

(It really doesn’t hurt anything, although it sounds awful, and it’s not something you want to do with every print, but it’s better for you to let it finish without turning off the machine halfway through.)

If the head is right underneath the camera when the unit is powered on, the first picture taken relays that information to Glowforge and they don’t use the standard startup. That’s why moving the head under the lid camera works. But I haven’t found it necessary to keep doing it. Usually doing it once after the machine has been turned off corrects the situation.

Just don’t move the head by hand any more than you need to, move it slowly when you do, and never when the machine is turned on.

As far as the calibrating taking a long time - that can have several causes. If it gets stuck, just turn off the machine, give it a minute and try again. If that still doesn’t fix it, reboot by holding the start button down for ten seconds until it turns teal, then turn off the machine, move the head into position under the lid camera, and turn it back on. That usually clears it.

If it doesn’t, the support group can usually pinpoint a problem from their end, but they will need more information from you about your browser and connections, so it’s a good idea to read through the Troubleshooting Tips section at the Support button on the app.

Finally, there are times when they are working on something on their end when everybody experiences some lags… it’s not something that tends to last for long, so for now, I just work around them. (Part and parcel of getting the units up front, and I’d much rather have it so I can play between the hiccups.) :wink:


I wonder what the difference is… I was out of town most of the weekend but have had zero issues with jobs today (calibration, loading times, etc.).

I’m wondering what kind of individual variations in the machine or in the operating environment factor into all these calibration issues. I know the weekend had some cloud-based issues for some but Sunday afternoon and evening were good for me and I haven’t had any calibration problems all yesterday and nothing so far this evening. I just keep printing job after job and it just keeps going. The jobs are anywhere from 1 1/2 to 2 hours. I’ve not gotten stuck. Wondering what’s going on.



1 Like

Yes, Very strange. I thought that I may have Internet issues. So I jumped over to my telly and got a 4K movie which loaded immediately and played in full res. Then back to the GF around two thirty. Restarted once again and was able to run several jobs without a callibration hiccup. It would be nice if the GF folks would post that we may have network or app issues at such a time. Or do they somewhere?

Does anyone know if they are developing in a worst case network setup with secondary cloud access? Or are they developing with the primary operations that we all use. If they are developing/testing on a super fast network with minimal cloud traffic they may not be seeing what the rest of the world sees.

I always had my design groups, design in a worst case environment with minimal memory etc. But that was in the days when 10 MB drives where massive.

1 Like

Exactly this! mine does it every now and then, I always wince even though I know it’s not that bad. They must have done some improvements, I don’t think I’ve had a failed calibration in over a month.

1 Like

Got my pro a couple weeks ago. When first turned on it went through the calibration dance 2 or three times. Probably needed to update from the factory settings. Other than that it calibrates once every morning when first turned on and never again. If I remember correctly it says calibrating or needs calibration for a few seconds between prints but never does. Just goes to Ready soon after.

Pretty much have had zero problems with two different machines since February. Yeah the GF S/W is glitchy but have quickly learned what not to do to work around almost every issue. Nothing has moved past the “slightly irritating” level for me. The generic error related to Preparing for a large/long print is the only one that I can’t always predict. Will be happy to see that one go away.


I remember those days!

I was one of the first people in South Australia to have an Amiga500 with a connected 512kb Drive… at the time i literally did not know what to do with all the extra space!

1 Like

This PRU works fine, and the files always print right where I put them. I have had the same ‘scanning’ hang a few times, but like Rick, nothing above a minor annoyance, and I was always able to finish the job.
Same hardware, I’m wondering how well their calibration proceedure is working out. Besides WiFi signal strength and room lighting, I can’t think of another variable that would manifest in such different behavior between machines.

Ditto me. (or is that tritto?)


I had a 500. A 2000 for a while, then a 1200. I gotta be honest… I just got rid of the 1200 this year. :slight_smile: But I dumped the hard drive so I can still run it in the emulator forever and ever and ever and ever. :slight_smile:

1 Like

The Amiga500 was an incredible computer for its time.

I have a Finnish friend who still runs his 1200 too! I can seriously understand why people still use them (IRL or virtually).


Tried most of what I could find to try online and sent support a note, then gave up for the evening and left it unplugged. I tried one more thing- turning on the A/C even though it’s cooler than normal here (I live in southwest FL) as I remember seeing that the operational temperature range is up to 81 degrees and (I think 85% humidity?). In FL, if it is < 81, there’s a good chance it’s >70% humidity, so I thought maybe some temperature and/or humidity failsafe activated? I mean it couldn’t hurt to try. For whatever reason it was willing to move the head this morning and I have a print going currently. I will probably go find a digital thermometer and hygrometer that I can leave near the unit as a gauge of whether I need to adjust the A/C before printing.

1 Like

Aaah, yes. If that’s a basic model, you’ll definitely want to run the AC. I ultimately wound up making the decision to upgrade to the pro model to get the higher temp range…our temps are similar range, for humidity … yours is probably a little worse, so the unit will pause when it gets too warm and needs to cool. There should be a message in the app (I think), just look there to see what’s going on.

It should be in the upper right of the GFUI next to the Print - it will usually say “cooling down” or something to that effect. The Print button next to it will change color (amber?) too. It’s been awhile since I got it again so I’m not certain as to the text.

On my PRU, the button on the machine may not change color and it will just pause.

1 Like

I think that’s with the Pro. Basic, I believe, requires it to be considerably cooler. <75ºF I think.

1 Like

Thanks for reaching out.

The Glowforge Basic is designed for use between 60 degrees Fahrenheit (16 Celsius) and 75°F (24°C).

Did you notice a yellow button? When your Glowforge can’t print, the button turns yellow. Like @Jules and @jamesdhatch said, check to see what you can do to resolve the problem.

If the environment your Glowforge is in is under 75°F and you are still experiencing problems, please let me know.