Calibration of Death


#1

Switched my Glowforge on tonight after a few weeks of non-use and… damn. I can’t seem to get past “Calibrating…” The button pulses white every now and then, but that’s about it. The app shows a weeks-old stale image of the bed and won’t let me update it. I’ve restarted both the 'Forge and my browsers multiple times, cleared caches and cookies, gone through the steps to reconnect the 'Forge to my WiFi (that worked fine), and still nada. No progress as of the latest reboot, and it’s been about 30 minutes.

shrug

Guess I’ll let it hang out for an hour or two and see if it auto-resolves, but otherwise… any takers? I think my Glowforge’s WiFi might be cursed or something. I’m constantly having to retry prints because the thing will suddenly go into “Calibrating the head of your Glowforge…” mode, and now this. And no WiFi issues with any of my other devices…

And I was looking forward to a night of burning stuff, too. :*(


#2

Mine ain’t doing much (anything) either and I’ve never had an issue with calibration from day 1. I’m guessing that they have a service down?

If it recalibrates after the initial calibration (the whole moving the head etc), it typically means your WiFi connection is dropping.


#3

Used mine a few hours ago with no issues.

Just powered it up and it all worked normal.
Did it sort out for you since you responded to this thread?


#4

Yeah, that’s what I’ve heard. And that’s pretty infuriating too. Generally there seems to be a serious robustness issue with the connection between the cloud and the Glowforge. If I can stream video and do just about any other online activity without experiencing disruptions, sending a print to the Glowforge should Just Work. Right? And heck, if something is lost in transit, …maybe automatically retry? Anything but another five-minute calibration routine. As a remedy for a dropped packet, that makes positively no sense whatsoever.

Ok, I’ll stop ranting. :slight_smile:

Back to the topic: It’s been an hour, and still stuck at Calibrating. :-/ Might leave it on over night just to say I did.


#5

Yup. Looked at the router admin screen and then rebooted the router a minute ago from the phone. I heard it calibrate just a second ago.

It’s weird; I usually have about 13 devices connected. Occasionally, around 1/2 of them will just drop off. Tv still works etc, but both printers, Glowforge, etc all won’t establish a connection until router is rebooted.


#6

Hadn’t thought to reboot my router, but I did that just now as well (heck, I’ll try anything). Also switched the 'Forge off and back on after I’d done the same with the router. Alas! It appears to be calibrating (forever) again.


#7

If you shut it off while it is updating it can get hung up. If it had been off for several weeks, it might have been trying to update and shutting it down before it finishes “confuses” the messages being sent to the cloud, for lack of a better term.

Best thing to do, and I’m not sure what to tell you to fix the current problem, is to turn the machine on while the app is closed, let it finish the startup calibration, even if it takes a while, and then once the head returns to the home position, only then do you enter the app.

I’ve hung mine up twice by getting impatient. It took running through everything - turning off the machine, unplugging it for a few minutes, rebooting the router, the computer, logging out of the app on all devices and clearing the cache on all browsers…then turning on the machine and waiting while it did it’s startup calibration. And if it has been hung up, that can take up to thirty or forty minutes.

Don’t know if that will work in this case. But as a best practice I like to turn the machine on before entering the app and letting it do it’s thing before starting to send it orders. It causes a heck of a lot fewer problems.

Good luck.


#8

Thanks! I do plan on leaving it on over night–while logged out of the app, etc. Fingers crossed. In case it means anything: The head never moves, and remains in the home position. When I power it up, I get the click-click-click, click-click-click for a little while (like usual), the cooling system seems to engage (again like usual), and then…nothing. Just fan noise. Never does the head move. The button glows white every now and then, but there’s no pattern that I can discern.

More tomorrow! My patience is gone for tonight. Zzzzzz…


#9

Yawn, stretch, …

Nope, still stuck at Calibrating after 9 hours. Switched off/back on and waited another ten minutes. No head movement, back at Calibrating.

Something seems broken. :frowning:


#10

I would take a looksie at some of the connections, just to rule them out. I have inadvertently loosened the cable ribbon connector that plugs into the head while cleaning. That will cause a failed calibration (it thinks it has been decapitated!). Also, double check the connectors for the lid camera (should be 3 - one on the lid by the camera, one on the left side of the lid, and another on the back of the case beneath the lid on the right hand side).


#11

Thanks! Did these things just now. I removed and reinstalled the head unit just for kicks. Those little FPC connections around the lid look like trouble to mess with, and as I didn’t see any obvious signs of their being unplugged, I left them alone. Fired the thing back up and still stuck at Calibrating. D’oh!

As an aside, when I removed the head unit, I pulled it forward and to the right of the home position–roughly centering it over the bed. As before, no head movement. It’s been on for about 10 minutes and the head is still positioned where I left it.


#12

To the best of my knowledge, when you manually ‘move’ the head you need to reposition directly under the camera before powering up.
Think of it as doing a HOME position manually.


#13

Smells like a warranty repair. I wonder how many machines Glowforge has already had to replace.


#14

Nah… at least in my experience… you can move it pretty much wherever and will calibrate. After cleaning, I tend to not move the head back to the corner or under the camera, etc. just leave it where it is and it calibrates fine.


#15

I’m beginning to fear the same–which is quite deflating, since my current unit is a warranty replacement. (The first one did everything except actually fire the laser.)

UPDATE: Still calibrating. It’s been calibrating (with a handful of seconds-long breaks, granted) for about 24 hours now.

A fellow user helped me retrieve the logs from my 'Forge (thank you!), and we’ve been looking at them. Lots of ‘error’ and ‘failure’ messages, however most/all of these appear to be benign noise, as they’ve been happening for months. Glowforge Support, please take a look when you can. For now, it seems I have a very large (and pretty, yes!) brick on my desk. :cry:


#16

Bump. Any takers over at Glowforge? I tried the software update steps described in the Calibration Hell thread:

…and the unit did appear to update and reboot, however the head still doesn’t move, and the web app still shows “Calibrating” without any apparent forward progress.

Fingers crossed that, one way or another, I’ll be 'Forging again soon.


#17

I’m so sorry you’re having trouble.

I extracted the logs to look into the issue, and it appears the lighting in your room is very bright. Do you have a lamp shining over your Glowforge? I believe adjusting the lighting could help improve the situation. Can you let us know if adjusting the light in the room makes any difference?


#18

Thanks pip! Yes, there is a west-facing window near by, and I generally use the Glowforge in the evening, when the sun is shining through that window. That said, I did leave the unit running over night and it never recovered. Also power-cycled it the next morning, when there was no sun IIRC. When I get home tonight, I’ll reduce the light drastically and give it another go. More shortly!

Best,
Aaron


#19

Hi again, pip. Unfortunately the lighting issue appears to be a red herring. I pretty much blacked out the room by hanging a thick quilt over the window and turning off the overhead lighting. The quilt fell down about 10 minutes into my first test because (apparently) I don’t know how to use thumbtacks. I hung it back up and tried again. We’re now 20+ minutes into the second test, and the head of the Glowforge still hasn’t moved at all.

Next steps?

Also–I’m not sure how the brightness of the room was indicated, but…–I should reiterate that the bed image does not update, at least not through the app. Presently, the app shows a very dark image with no material present, which I’m 99% sure is from weeks ago. As of the last power cycle, however, the Glowforge actually has a piece of white paper in it with the words, “Hello, Glowforge!” handwritten on it in large green letters. FWIW!


#20

Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.