Camera will not focus, blurry image

I have seen and looked at several other posts, but none of them seem to address my issue. I turned on my GF today and the camera refuses to focus. I have used the “Set Focus” feature and chosen various spots around the bed. I have tried various materials of 1/4" or thinner but to no avail. I do not get any error messages, and the head moves just fine. But the image shown on the GF web interface is always very blurry, regardless of where I choose to focus.

I have tried a simple power on/power off cycle but that did not help. I also tried holding the button down for several seconds and then reconnecting my GF to WiFi, but that did not help either.

Does anyone have any ideas as to what is going on here?

The focus is fixed during assembly. The “set focus” option doesn’t change the focus, it just adjusts the image to match the thickness of you material.

Have you tried cleaning the lens?

Yes, I have cleaned the lens. I have had my GF for several years and the camera has always worked fine. The GF was just used earlier this week without issue. I am not sure what has changed.

Can you see any damage on the lens itself or possibly any debris on the inside of the lens? Support staff will probably need you to take some photos of it anyway to help diagnose the issue.

It looks like the physical lid camera connection was loosened and turned…it’s supposed to be glued in.

Does it shift when you gently twist it?


Yep. That did it! The lens was indeed loose. Thanks for the tip. I was able to twist it counter clockwise until the image came back into focus.

@mlampart I’m glad to hear that your camera is no longer blurry. Thanks for the answer @ Jules , that’s right. I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!