Cannot load Glowforge app, nor find GF wifi

I’ve had my GF unplugged for a couple of months. Today I plugged it back in and powered it on. I could not get the Dashboard to load. After reading through Troubleshooting, thought I might need to reestablish the wifi connection but discovered that my GF is not showing up in the wifi menu. I have recycled the router, the power, the ethernet cable… not sure what to try next or how to at least re-do the setup process.

Any suggestions?

I did figure out that pressing/holding the power button will yield the teal button. I was able to see my GF in the wifi networks. Using an iPad, I can see the dashboard and my GF unit, which shows “Ready.” BUT I cannot see anything on the Dashboard/GF app on my desktop computer. I have tried logging out from my iPad in case there can be only one device connected to the app/Dashboard at one time. Not luck.

Multiple connections are fine.

So no designs are showing up in your workspace?

Do you have multiple users assigned to the machine? Each user will have their own design space and not be able to access other users designs.

Just me.

I can get things to print using the iPad’s browser. But when I try from the laptop, all I get is a blank (white) screen. Nothing loads.

Sounds like a browser issue.

For support to have more details, you might go to and post the results.

In the meantime, what browser are you using and have you tried a different browser on the laptop? Chrome generally seems to work the best.

I’ll try Chrome when I get back home in a couple of days. Been using Safari without issue. What’s funny is that my saved bookmark for GF app wasn’t in the browser toolbar. Coincidence probably but a strange one nonetheless.

1 Like

Nope cache or cookies issue. Clear your browser’s cache and restart it. Then reload and it should fix your issue


Ahhhhh. Thank you! I’ll do that when I get home!

I tried this solution, but it did not work. I cleared the cache and deleted cookies from Glowforge. Still the same, blank page. However, the page opens normally using Chrome.

Huh. Another Safari special behavior. I think GF does the bulk of their testing using Chrome - that’s the one that seems to be most consistent in behavior.

I’ll have to check with my wife to see if they’ve dropped another security tweak that’s caused her similar issues (she’s the primary Appleoid in the house).

I really appreciate your help with this. Thank you.

Hey @ jetfire68, I am sorry you hit a snag! I see you already emailed us about this and we’re working on it there, so I’m going to close this topic. Please feel free to start a new thread if you run into any other issues. Thanks!