Can't get past "Preparing to Print"

It’s a fairly simple engrave. I’ve left it for 30 minutes and it just sits there spinning, and never goes anywhere.

I’ve tried reconnecting to wifi, making sure it’s on the same network as the laptop (which is immediately next to it), I’ve let it re-“home”, I’ve turned it on and off again.

The more I use the Glowforge the more problems seem to come up. I don’t want to say I’m regretting this purchase, but the amount of footwork I need to do in order to just get the machine to do… literally anything? Is exhausting and annoying.

The only way the machine EVER seems to work is if I’m using Proofgrade materials, which… isn’t practical. The materials (and the shipping!) are expensive, they come in limited varieties (most of which I can’t use), and which are frequently out of stock altogether. I’m starting to think GF has updated their software to automatically make using non-PG materials cause problems, and I’m feeling very bitter about it.

1 Like

I’m having the same issues with printing as well this morning. Normally it is fairly quick so my guess is issues with the service (overloaded perhaps with other user requests?).

Check out other parts of this forum for settings regarding using non-proofgrade materials. Anyone on here can tell you it takes a bit of practice and trial/error to get the settings correct. That would go for any other laser machine, you just need to use sacrificial scraps to hone-in your GF settings. I’d say I’m using about 50% proofgrade for my projects just because as you stated if you want to sell the items the cost of materials is prohibitive.

I’ve been reading tutorials and following suggestions all morning. None of them help – the machine just refuses to work.

People have been reporting problems for at least the last 3 days now. My own Glowforge has been “down” for at least 72 hours… always stuck on “Centering”.


1 Like

The fact that we are still at the mercy of their servers is outrageous


“Still at the mercy…”? Did you not know this was a cloud based product when you purchased it? We will ALWAYS be “at the mercy” of their servers.


This is just a fact of how the hardware is constructed. If you want a no server small laser cutter in 2020, unfortunately you’ll have to buy a different brand.

“Stuck on centering” is reported by at least several people every day, not just when there are outages. It’s a VERY common issue with these machines. Since no outage is being reported, it would make sense to go ahead and work through the troubleshooting steps. There’s a pretty good chance you can find the problem and get yourself back in operation. :slight_smile:

I purchased two Glowforges back in 2015 and waited almost two years for delivery. I’ve been using a Glowforge since the day I purchased it and never had an issue like this.

What troubleshooting steps would you suggest? Here’s what I’ve done so far:

  1. Cleaned the wide angle camera on the lid.
  2. Cleaned all laser ports, lenses, and mirrors.
  3. Cleaned the air assist fan on the print head.
  4. Cleaned the contact pins on the print head.
  5. Cycled the power on the machine (several times).
  6. Left the machine on/off for several hours at a time.
  7. Reset the Wi-Fi completely by holding down the Glowforge button and redoing “Setup”.
  8. Tested the Wi-Fi in my house. 130+Mbps and a signal strength of -32dBm at the Glowforge itself (ie. Excellent).
  9. Manually positioned the arm and print head under the camera (then turned on power).
  10. Manually positioned the arm and print head to the upper left (then turned on power).
  11. Tried starting up with Proofgrade material in the Glowforge.
  12. Tried starting up with the Glowforge bed completely empty.
  13. Unplugged machine for several hours and just walked away before trying again.
  14. Visually inspected pretty much everything I can think of.

What (if anything) did I miss?

1 Like

Cell phone hotspot – that’s the best way to rule out wifi.

You may have the dreaded black cable failure, if the hotspot doesn’t help. :frowning:

Can also report problem with printing stuck in “preparing” I have been stuck here for 10 minutes still wont let me do the job.
I’m ready to get rid of my GF and get a real machine that let’s me use PC based software and not pray that the company servers are down or they go under.
Or GF can just make PC based software :wink:

You should start your own thread in Problems and Support wrt this issue.

It’s the same issue…

Even with the same issue, starting your own thread will trigger a support ticket, so that you can get help individually.

It’s not the wi-fi… LOL

I was about to do the good old “basic sanity check” anyway… and this email just came in.

…and it’s official.

Degraded performance

New incident: Investigating

The team has identified an issue impacting performance of Glowforge Print services. Some users may encounter slower than usual performance when uploading, preparing prints, calibrating and refreshing lid images. The team is currently working on a fix for the issue.

Time posted

Sep 28, 10:50 PDT

1 Like

Hopefully that will fix it for you!

I sure hope so! The Glowforge has been a fantastic product for me over the years. Aside from ONE issue (covered under warranty), I have not had any problems… and certainly nothing like this.

I’m in a slight panic as we’re now in the “busy season” and I really need to get back up and running. If that means I have to rent a machine or buy another one… so be it… but I need to get back online. :slight_smile:

Still want to blame my wifi?

Maybe, maybe not. Since you wouldn’t try the cell phone hotspot, we’ll just have to wait and see. :slight_smile:

Actually if you read my post I made last night I did try the hotspot trick and it did not change anything. But hey like I said guess we should buy lottery tickets since we are only a “Handful” of people having problems.