Can't get past Terms and Conditions


#1

I’m trying to set up my new GlowForge; finally got to the online part. I go to setup.glowforge.com, scroll through the whole document to the bottom, check the box saying I’ve read it…and nothing. The “I agree” button remains stubbornly greyed out (see screenshot). I’ve cleared my cache, turned off ad blocker, restarted the browser – no joy. Running latest versions of Chrome and Mac OS on a MacBook Pro. Support email says THREE DAYS for a response. I have already waited 2.5 years; I want to LASER SOMETHING!!! Can anyone help?


#2

Have you tried a different browser?


#3

Geez, maybe try a different browser… ?
After a two year wait - what form of madness is this!?


#4

I’ve also tried on my iPad and iPhone, with the same result. I haven’t loaded another browser on the computer, because that hints to me the problem isn’t on my end.


#5

I’ve got nothing better to do right now, though, so I guess I’ll give that a try. sigh


#6

The problem might not be on your end, but pretty sure there are other instances of chrome and glowforge not always playing nice with eachother.


#7

Nope. Same result in Firefox. :frowning:


#8

I’m having the same problem. Did you find a solution?


#9

Oh, that sucks. Sorry, buddy. I know waiting a minute longer once you have it is excruciating.


#10

You might try whatsmybrowser to see if it is up to date.
At the direction of support, I have had that identify a problem.


#11

It’s like the problems never end! The boxes that the Glowforge was shipped to me in was beat to hell and back by UPS with tears, punctures, handles missing. They even completely disregarded the picture that said “THIS SIDE UP” and had the machine COMPLETELY UPSIDE DOWN AND THEN TILTED ON ITS SIDE! And now I can’t even test the machine to make sure everything works before I know whether or not to send it back. Even then, I don’t think I can reship the box with the condition that it’s in. I am beyond upset right now. AND I can’t even access the free designs that were promised to me in the email. grrrrrrrrrrrr…


#12

Tried it–I don’t see any issues…Java isn’t enabled, but I can’t see that it should require Java, should it?


#13

I don’t know enough to answer that question, sorry - but someone here will.

Edit; Mine doesn’t either, so apparently not.


#14

It will be ok! I get youre frustrated. So far, theyve been super good about taking care of customers. You might need to open a new thread in problems & support to let staff know that youre having an issue. If the box is too damaged to ship back, they’ll send you a new box. But like many of us experienced, a damaged box doesn’t necessarily mean anything is wrong. My box was held together by hopes and dreams by the time I got it, and everything was totally fine.

I hope they get the set up stuff sorted out soon for you guys. When everything is working, you’ll love it.


#15

Could someone who’s already been through the setup go to setup.glowforge.com and see if your url says something different from “entry=first” at the end? This is what mine looks like:

https://glowforge.com/setup/terms-and-conditions?entry=first

I’m grasping at straws, but thinking maybe a different “entry” value might let me go past…?


#16

We’re looking into this and will write back when we know more. I’m sorry for the frustration!

@hulksta18, please do open a new thread if you have a question for us.


#17

Please hurry! This is the only day I have to play until the weekend. :disappointed_relieved: (Unless it keeps snowing, that is…!)


#18

And thanks. I feel more hopeful now, at least!


#19

Thank you for your patience! Would you please try accepting the Terms and Conditions again? Please let us know if you experience any trouble.


#20

It let me in!!! Can you hear me squealing? :wink: