Can't get this window to go away

Help - this window won’t go away so I can’t print anything!
Tried clicking, escaping, reloading, and nothing works. Any ideas?

Just to check… try a different browser. Might need to clear the cache, drop cookies, etc.

Tried Chrome and Safari. Same issue.

Suddenly went away. Very strange. Thanks anyway.

Might have been updating the software in the background and therefore was not ready? Could be good to give people a heads up that they may need to wait 10-15 minutes especially if they haven’t printed in a while.

Possible, but as long as it’s gone now… Keep your fingers crossed it’s not a recurring issue. :slight_smile:

Yay to hear your problem fixed itself - but FYI for anyone else, I had to click the arrow and go into the presentation before I got an X to close out…

I’m sorry you ran into trouble with this - thanks for letting us know, and I’m glad you were able to get up and printing. I’ve passed this feedback on to the team so we can look into what happened.

If you run into any other trouble, please start a new topic or email us at Thanks!

1 Like

Thank you. Yes, I believe that the slide show was a bit “aggressive.” I clicked the original arrow but did not see that there were consecutive “slides” afterwards. Didn’t see an "x’ to get me out. Perhaps it can be made more obvious in the future or in the very least you can have it close with an esc key. Esc key to exit just about anything is standard so at the risk of missing your carefully crafted slide show you may want to give the user some option to exit with a keystroke because the interface is not obvious or is different depending on the browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.