Can't log in using Firefox if "Enhanced Tracking Protection" is enabled

I’m using the latest version of Firefox, and have “Enhanced Tracking Protection” turned on.

This makes it impossible to log in. Here’s a picture of the network activity window:

Probably because it’s using the Firefox window as a passthrough to the :glowforge: so it has to know who exactly you are and what you’re clicking.

Turn if off! :sunglasses:

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop#w_adjust-your-global-enhanced-tracking-protection-settings

You know where you are and what you’re doing, turn off the tracking.

I was not able to reproduce this. I logged in using Firefox without disabling ITP.

I also tried resetting all privacy data, setting my protection level to “Strict”, and logging in again.

No issue again.

Perhaps you have some other addon or software installed that’s causing you this problem.

ss

fwiw, I am also unable to log in at all with the latest update of Firefox on Mac, no matter what settings I use.

I don’t use Firefox (for the GF) - I use Chrome - but I just tried to check as I was curious. It’s like the Sign In feature is completely broken.

Try a different browser.

Oh no, I’m sorry to hear about the trouble, and for our delayed response.

While our team investigates this trouble further, would you let me know if you can log in by using another browser?




Yes, I can log in with Chrome and with Firefox with the enhanced tracking protection OFF.

I am on a Mac, if that matters. I’ve already turned off AdBlock.

Thanks for these details. Enhanced Tracking Protection is a security feature that can limit some site functionality, but from the feedback I’m seeing in this thread, this isn’t a consistent issue. I can easily reproduce this behavior when Enhanced Tracking Protection is enabled on Firefox, for instance, but it looks like this isn’t universally the case (some others on this thread are able to sign in just fine with ETP enabled). I’m also on a Mac.

I’ll work with the team to do a bit more digging into possible differences in this behavior between Mac and Windows, and I’ll let you know when there are any developments. I’m sorry for the inconvenience in the meantime.

We’ve done some more testing, and we’re able to reproduce this behavior on MacOS only. The team is looking into it now. Until we’re able to fully resolve this, I’m afraid the workaround I suggest is either using a different browser, or disabling ETP on Firefox for glowforge.com. I’m terribly sorry for the inconvenience, but thank you again for bringing this to our attention.