Can't upload a file

Yes, it’s a .svg.

No, I’ve never had a problem before.

I am running a MacBook Pro with latest Firefox. I clicked on the ‘upload’ button. As it has done dozens of times before, a window pups up for me to choose the file. I do so.

Immediately another dialog box opens, advising me that I can drag a file anywhere to upload it, or I can browse my computer for the file. This dialog has never appeared to me before. I chose the ‘browse’ option. That gives me the Finder window again. I click on the desired file.

That gives me another dialog box stating " We’re sorry, an unexpected error has occurred."

So I tried restarting the whole thing, this time dragging and dropping. Ended up with the apology again.

Closed the GFUI, re-opened. Same effect.

Ideas? Everything was working fine last night.

1 Like

I had the same issue this morning. I had to restart my computer now it work s fine…

1 Like

Tried a restart - no worky.

There’s a second dialog box lurking behind the ‘apology’ box. I have to be fast to read it, but one of the lines is in red and says ‘you can’t upload any more files’.

Is there a limit? I just trashed a bunch of files that I won’t need any time soon just in case there’s a limit.

A couple other pieces of information seem to be relevant in previous discussions about this behavior. Especially if you are using Firefox that has been updated.

What design software for the SVG?

Have you cleared your cache?

Does it replicate the behavior with Chrome or Safari?

Works in Safari, so now I’m wondering what’s wrong with Firefox. they just pushed an update.

1 Like

Thanks for reaching out, and I’m sorry you hit a snag. Are you still unable to upload your file using Firefox? If so, could you please share the file you’re having trouble with? You can post it here, or email it to us at, and we’ll be glad to take a look.


It’s curious. I just uploaded another random file with no difficulties. I uploaded THIS file RaspPi_B_Typ_2 easily using Safari on my MacBook Pro. I uploaded this file oneinchriser without issue using Firefox, but I still can’t get that first file to upload in Firefox.

I’m adding ‘swap browsers’ to my arsenal of troubleshooting tools.

I noticed when I try to open the SVG you provided with a browser, there is an error. Different browsers I tried had different details, but they all point the the same problem in the file.

As a workaround, I was able to get the file to upload in Firefox when I did the following:

  1. Open the file in Inkscape

  2. Save As … Plain SVG

  3. Upload again to the Glowforge app

Can you give that a try, and let me know if you’re still having trouble?

This is my first ever upload on my brand new GF, and for 2 hours that is the only message I have gotten…I keep trying because I want it work…I just thought the system was very slow…

Now I get no messages, just no response when I click upload and click to open my plain svg file…


I changed the saved version on my computer to a plain SVG and it uploaded just fine.

I’d read somewhere about the possibility of Inkscape’s SVG being ‘quirky’ but I didn’t notice that the file had saved in that format. I’ll watch it a bit more carefully in the future.


1 Like

I just switched from Chrome to Firefox and am currently making my first upload print…sooo happy

1 Like

That’s a hoot! I couldn’t get a file to upload in Firefox, but it worked in Safari. After following Pip’s advice, it uploads in Firefox.

Have fun!


I’m glad you resolved it! I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!

We try to keep to one topic per post in the Problems and Support section. Can you create a new post with this question if you’re still having any trouble?