Can't view or use outside cut line on file from affinity designer

From the included screenshot image the outside cutout line will not show or allow to set cut parameters, and the error shows "we can’t process masks yet”. As can be seen in the screenshot there is a top box (shown by red arrow) to enter settings, but nothing in it to set! The file is in pdf format and is exported from affinity designer. Any way to make outside cut line able to cut?

1 Like

Does that cut line have a stroke set in Affinity?

1 Like

Yes 3pt

1 Like

It looks like it’s there on your design - have you tried choosing a material (or adding an uncertified material) and seeing if you can set a setting? It’s possible that 3pt is too fine a line for the thumbnail to render.

The mask warning probably means you’ve got an empty mask in the background somewhere, otherwise there would be a portion of your art that you wouldn’t expect to see that is showing up.

1 Like

It’s showing no artwork which typically means it’s outside the ‘cut’ area. Try to shrink the size and just see if that’s the issue. If/when it fits, you should be able to cut. Not saying that’s what size you need to cut it, just a test to see if that’s the issue. The bottom is easy to see it’s okay, the rest i can’t tell…

I’ll try those things and reply back if it works. Thanks for the input.

1 Like

How can I tell or remove the mask in affinity designer if that’s the case?

1 Like

Resizing does not work and when I try to change/set settings I get a shadow of the engraved items from the box below the top one with the red arrow shown in the new screenshot after I made the changes. Please note the error message in the lower right corner. Is this a result of a mask, and how do I get rid of it in affinity designer?

Here is the pdf file that I uploaded in the GFUI if anyone would like to look at it.

2 image frame - top.pdf (735.2 KB)

When i pull this into GF, it’s the same as yours. I pulled it into Inkscape. When i ungroup things, everything is a path except this and it is an image, ‘imbedded; masked in root’.

it will take someone much more knowledgeable about Inkscape to give you advice on how to fix it-but at least i think we understand the problem, it’s the file not GF…

I decided to try to tackle this:-) I was able to release the mask that was applied and then do node editing removing the outside of the mask on what was left. I have attached it here. I did pull it into GF and it’s showing as a cut now. I’m sure there’s a better way but at least you can proceed!
revised 2 image frame - top


Thanks for your reply and input and effort in trying to figure this out. A couple of questions and statements are in order here.

Have you figured out by your effort what I may have done wrong in affinity designer so that I won’t repeat this mistake again? Is it because I added an embedded image? Because I’m pretty sure I converted everything to curves since everything showed that they were converted in the layer sections in affinity designer. Have I missed something here?

From the quote above I’m not sure what you meant by “everything is a path except this…”What are you referring to that is this?

Also I’m not sure what I can do with the image you provided after your editing unless I can download that as a pdf file, but I’m not sure how to do that from this forum.

I’m not sure if you know this or if anyone else can chime in, how do you release a mask in affinity designer since you did that in Inkscape which I don’t use? I only use it when I have to, because as I have found out and from what others who have used it have said on the Inkscape forum, it is super slow and very buggy on iMac computers.

Right click and Save As .svg (or the Mac equivalent of right click :slight_smile: ) and you can load that to the GFUI.
Saving as .pdf also works - both svg and pdf are container files that can have both rasters and vectors in them.

1 Like

In Inkscape, when you click on an object it tells you what it is i.e. group, path, text, etc. When i broke this apart, it showed it was the imbedded; masked in the root. I really have no idea what this means but was able to ‘release’ the mask and i edited the nodes from there. I didn’t realize you did the file yourself. There are lots who know about Affinity here that may be able to help you.

And, as @deirdrebeth said, if you right click on the image i posted you can save this as the svg and it will pull right into GF.

The only issue is that if I pull it directly into the GFUI the way it is the font is incorrect and has changed on some of the text. I will try to do a save as on my computer and then open it in affinity designer first to change the text font if that will work.

Although that may work, it still doesn’t answer the questions I had about affinity designer and the mask error shown on the bottom right of the screenshots and how to deal with them in affinity Designer, but thanks again for the effort.

You could pull both of them in and set to ignore everything on the svg except the outer cut and use the one you did in affinity for the rest…

hopefully someone will be able to give you some advice on affinity. I usually do a search on google asking what i need to know and you many times get a youtube that can show you…

Good luck!

Yeah I’ve done that search and haven’t found what I need. I tried uploading the file from save as and the scale is way off on the svg file. That also happened to me and that is why I used the pdf format to upload instead, which kept the scale intact from affinity designer. I need the scale to be exact since there is another back piece that the images will attach to and the screws holes for both top and bottom pieces need to align as well as the score marks for the bottom piece needs to match the cutouts of the top piece. The images are slightly larger than the top piece cutouts to cover the edges of the photos on the back/bottom piece.

As you can see in the pics below now even the scale of the pdf is way off. Did you scale the image in Inkscape? The next image below is the svg file and the other one below that is pdf:

No, i didn’t do any scaling, and saved as 96dpi…

Well after a few hours of digging I finally found the answers I needed to make the svg file to work. First, using the information on the following thread I can now make svg uploads to GFUI:

An excerpt from above link:

Sep '17

Okay, I think you nailed it!

One way to avoid mucking around with post-processing the SVG is to click the More button on the Export pane. Set “Use DPI” to 96 instead of document resolution, unset “Set viewBox”, and while we’re in here might as well set “Export text as curves”. Click Manage Presets to add a preset, name it Glowforge, and use that from then on. The result is no viewBox parameter is set on the root node and the width/height is set in pixels at 96 DPI. Result imports at the right size.

Secondly, the mask seemed to appear from the outside cutout curve, so I redrew the curve and deleted the old outside curve and now the file uploads at the correct scale and no error message appears about mask issues. I’m not clear as to what happened so if anyone knows please reply.

I would still like to know why the error message occured (see above pics in the lower right corner) and what I did to cause the issue. Also it would be nice to know how to get rid of the mask should this occur again and not have to redraw the curve that caused the issue.

Thanks all for the input!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.