Carriage Plate Clicking

Believe me when I say I have been at this for about 5 hours now. I have already emailed support and thinking I will need a whole new carriage plate (which I am willing to pay for). My machine is no longer under warranty. My lines weren’t aligning but just a hair line. Or when I engraved it became out of line. I’ll post an example. Below are two golden retrievers i engraved. The one on the left is one I did that turned out great!! The one on the right you can see by the nose that the engraving starts to shift.

I took of the carriage plate, adjusted tension on the belt, cleaned everything. It still is skipping lines or engraving lines.

When I move the carriage plate back and forth there’s hesitation and like a clicking noise. I have examined everything. The belt there was a slight fraying but when I looked to see if the belt moving interferes with that part it doesn’t at all. The frayed part is directly to the left of the plate so it doesn’t roll over the side pulley wheels at all. I also looked at all of the teeth on the belt and the wheels and I am not seeing anything. Here is a video of the noise it’s making. I don’t feel anything when it jumps or clicks. I cannot for the life of me figure it out but hoping it’s just the carriage plate that needs to be replaced and GF can assist me with replacing it :grinning:

1 Like

The wheels are ok?

I had a case where there was a screw loose that was causing friction. I posted about it, let me dig it up.

I don’t think This is your problem but your situation is weird so guess it couldn’t hurt to mention it.

HI thank you so much! yes I checked the wheels. It seems to work fine moving forward and backward only when the plate moves side to side that it skips.

Front and back wheels? The carriage has wheels in the back too.

Could be the bearings too, but I suspect the rail because it clunks once/twice in the same spot. If it were the wheels or bearings I’d expect it to clunkclunkclunk every rotation.

yes all of the wheels. How do I check the bearings?

I tried dragging my finger along underneath the railing to see if I felt anything and there’s no gap, no anything. It is smooth. It does seem to clunk every maybe inch (?) when I move it side to side.

Well then now it sounds like a wheel or bearing.

I’d take it entirely off and spin each wheel and see which of them has a hitch.

1 Like
is this right? All 4 wheels spinning perfectly fine. Just want to make sure I’m checking the right spot

What happens if you manually twist the motors? Do they clunk?

I’m so sorry for asking so many questions but for the motors, where would I find those and twist them? Are they directly on the carriage plate or the pulley wheels on the ends?

The pulley wheels. The motors are stepper motors and are the big chunky things. There should be one on the gantry that’s pills the head side to side. Spin that wheel and see if it clunks? See if the pulley on the other end clunks?

Btw I have no idea what I’m talking about, I’m just making guesses. Thing is there aren’t too many moving parts here. There are wheels On the carriage plate, and pulleys on the gantry. One pulley would be on the motor and the other should be free spinning on the other end of the gantry. The relatively low number of moving parts should make narrowing down the issue pretty possible.

The stepper motor looks something like this:

There are some other people who are pretty technically/mechanically savvy that might have more(better) ideas here. @shop, @timjedwards, @sqw, @bill.m.davis, @henryhbk among lots of others. Maybe they’ve got a bright idea or three?

Almost sounds like the belt is twisted.


Oh also @raymondking32 has done a lot of repairs on his Glowforge.

1 Like

This is true, though you’ve covered anything that I could imagine being the case. The stepper motors would be my best guess, especially with the inconsistency of it occuring.

Not as if it is actually the case, but are you using personal settings? You don’t have to tell me the specifics if you are, as that would make this a beyond the manual type disccusion and would constitute us having to move it to that section of the forum. If you’re using a really high speed, I could imagine the the head is moving out of place, or “slipping”. In the beginning when the machine is focusing things up, it records where the head should be, creating a 0,0 point. I’ve bumped the head in the past while pulling things out of the machine and it has caused some similar results to what you have.

There are actually a handful of discussions about this topic found here and over on the FB group, but since I’ve never had to deal with the problem personally, I’ve unfortunately very little to add to what has already been suggested. I’d definitely manually twist the those motors as evans mentioned to see if they’re not as smooth as you’d expect them to be.


My first thought of clicking is a stepper motor missing a step. Now that can be for several reasons, something is on the track for the v-wheels causing the motor to stall when it hits it (happens on the x-carve all the time with all the crap being thrown there) or the stepper current is set too low (not fixable by us on the Glowforge). A cracked bearing also will make a sound like that, so if the printer is off and you gently run the x-carriage back and forth (not too fast or you generate electricity) do you hear the sound?


I’d hope for an external cause and thoroughly vacuum. I’ve had a small piece of chaff cause troubles, as @henryhbk mentioned.

1 Like

None of the wheels have any cracks or damage, you mean?

Did the clunking start after the carriage plate was removed?

If so, I would start with things focused around that. Stepper motors do go out, but it’s a pretty uncommon occurrence.


Okay, I will check that! Thank you! I loosened the belt and that seemed to help with the carriage plate going back smoothly and clacking. GF is sending me a new belt and pulley wheel since the right wheel was cracked. I glued it back together just to try and get me through until the pieces ship to me. I am going to check the motor!

I actually was using proofgrade settings but tried to slow everything down because I thought maybe the same thing that it was just going too fast. But it still did it. I loosened the belt on the right side a little bit and things seem to move smoother when moving the plate back and forth. GF sent me out a new belt and pulley wheel since the wheel cracked. I glued it together until I get the new wheel hoping to just baby it along until then since I have some things to get done, but even with the plate moving smoother, I still have the laser bump or skip just a tiny bit. I will try and get a picture of it. I can still manage to get the piece out that I am cutting but just have to pop it out since there’s one tiny piece that didn’t cut.