Changing DPI/PPI

dpi
editing
svg

#1

At different times I’ve seen the GF editor interpret my SVGs as 96 DPI or approx. 90 DPI.

I.e. sometimes I upload an SVG with a 96px by 96px square and it’s exactly 1 inch by 1 inch, and sometimes I upload an SVG with a 90px by 90px square and it’s exactly 1 inch by 1 inch.

Is there a setting for this somewhere? Is it a property of my SVG files? Does GF sometimes change this setting or am I just losing my mind?


#2

I think this tutorial might be helpful for you:


#3

The UI doesn’t change its interpretation.There are several things that can cause resizing. How are you generating SVGs (what program) and what save options are you using?


#4

I’m using Inkscape, default settings.


#5

Do you know what version?


#6

Yep, .91


#7

0.91 uses 90 DPI. Upgrading to 0.92 will use 96 DPI, which will match the Glowforge UI.

http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92

The default resolution was changed from 90dpi to 96dpi, to match the CSS standard. For more background information, please see the Wiki article about handling of units in Inkscape. Inkscape 0.92 will attempt to identify ‘legacy’ Inkscape files that need to be converted. If such a file is detected, the user will be offered three options:
Set ‘viewBox’. Inkscape will add an appropriate ‘viewBox’ which will do a global scaling of the document. It will also adjust the document width and height if necessary.
Scale elements. Inkscape will scale each internal element.
Ignore. Do nothing. This is an appropriate choice for documents meant for screen display.


#8

Ah, that explains a lot. Thanks, I’ll upgrade.


#9

Thanks for the answer @jbmanning5. I’m going to close this thread - if that doesn’t resolve the issue, or if you have any other questions, go ahead and post a new topic.


#10