Community support on computer that has accessed new glowforge

Ok now what is wrong ever sence I set up my new glowforge I can’t access community support on that computer, I am having to use my phone right now


Do you mean that clicking on the “Community” tab doesn’t direct you here?

Yep,nothing happens

You did re-connect your device back to your normal wifi?

Yep, cleared browser cache rebooted computer, my phone is on the same network as my home computer but nothing on the home computer

… and you can access other web sites without issue?

Yep it’s just

Something weird with your browser, I think. Try a different browser for both the app and the community and see what happens.

Tried a different browser, it really makes no sense

Glowforge does not operate this forum, and others are not having this issue. I agree it makes no sense, but it could be a an ad blocker enabled at your end.

Can you share a screenshot of what you see when trying to access this site on that computer?

Basically I click on the community and the screen acts like it is gonna go but nothing but white on the screen, it happens on both computers that I have accesed my new glowforge which I received today, but I can still print

1 Like

You know it’s not the LAN to WAN bridge (or a Firewall implemented by the network provider on that bridge - like the IT department at a business) because other computers work.

If it happens with every browser on this PC, it’s not the browser.

If other PCs on the same network are successful, it’s not the LAN.

This really only leaves one possible culprit. You need to go take a look at the PC’s Firewall settings. That’s where all the network activity from every browser goes in order to get to the LAN or WAN. The Firewall (be it native or part of a 3rd party virus checker, there could be more than one) is where the network activity for that specific PC is subjected to rules that can control where or how the PC connects with the external network.

It’ll be a huge effort, but you could compare the firewall settings on a PC that works with the settings on the PC that doesn’t to maybe spot the rule that’s causing the problem. But it might be as easy as searching the firewall rules for “” and deleting any you find. I’d start there…


There is nothing in the firewall settings pointing to

The weird thing is one computer is a Chromebook (used to set-up WiFi on glowforge)

And other computer is my Dell XPS 8940 (used to access the app

Mark S

Ok, I can’t explain it. I fixed the problem. I used my phone as a hotspot connected via wifi to my phone’s Verizon data and it worked. Then reconnected my computer to my home network and now everything is ok.

Go Figure

Electronic gremlins. :man_shrugging:

LOL, well I get the new gremlins are that no pictures will load. This is the only site I have problems with. Can’t figure out why just because I added my new Glowforge a few days ago


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.