Complex SVG / vector files skipping entire sections


#1

So I have a somewhat complex, fully vector SVG file that I am trying to score. No rasters at all. It’s essentially a topo map with contour lines.

Twice I have tried to test this as a score and both times huge chunks of the file were missed. These missing pieces were always visible in the preview window . I placed everything onto one layer, with one stroke color, and still a different chunk was missing.

It appears as if the GF app is just leaving out pieces of the design.

Thoughts? Is there a node limit? There were no warnings on import and again, everything shows up in the preview as ready to score.

I’ve attached the single layer version that fails.

LakeBalboaTopo_Layer_v4_scoreTest


#2

You’ve got three small bits waaaaay off of the artboard. Those can keep the file from loading:

You’ll need to ungroup and delete those. Then once it does load, and it takes several minutes to render, you need to set the thickness of the material and then the score settings. Once you do it will take several minutes for the pink preview to completely render on the screen. Not the one that happens after you press the Print button, the one that happens before you press the print button. If you press the Print button before all of those lines show up on the screen, they will not be in the final version.

So set the settings, go do something else for fifteen minutes or so, and come back to check to see if they have all loaded. Then send it to Print.

I had one take 45 minutes once…it was a monster file, but it did process.


#3

Awesome, thanks for the quick reply @Jules. I think my main problem was not waiting for the pink preview to complete before I pressed Print. I thought about it, and said Nah, no one would design a UI like that! :confused:

Seems that pressing of Print should be locked out until the rendering is complete…

I’ll give this a shot and then finish my design work.


#4

many of us have been arguing this for a while. it’s definitely a bug, imo.


#5

You had some entities way out in space above and below, and some clipping paths.

I pulled the design into AI, cleaned up the extraneous bits and made it into a compound path. @jules showed you the “before” and here is a cleaned up version of your file for you to look at:

coloradocaver_topo

I made the lines red for no good reason :slight_smile: It loads pretty quick, less than a minute to get to this:

This is draft quality score on med draftboard time.


#6

Awesome. Yeah, I missed those bits floating out there.

This is actually going to be one of the multi-layer lake depth maps. Pretty much done with the main vector contours, just need to finish up the pretty work of adding in a legend, compass heading, etc.


#7

Show us the finished product when you get there. I’m sure it will look great.

FWIW, Proofgrade cuts on those lines would have taken twice as long.


#8

Your best bet on files like these, I think, is making sure A. The file is very clean. And B. Combining things into a compound path. The compound paths have a much easier time loading into the UI it seems like.


#9

I have to agree. Many times with the PRU I successfully ran a file without waiting for the screen to finish drawing. I haven’t tried it with this machine, There has been a time or two where I noticed something in the preview that saved me from trashing a piece of material. Usually placement. :face_with_raised_eyebrow:


#10

I can’t think of anything else you could call it. It’s certainly not a feature… The print button should not light up before the file is fully rendered to print.


#11

Thanks @jules! I believe that waiting for the pink preview to completely render will resolve the issue. If you find that it doesn’t, please open a new thread and we’ll dig deeper!


#12