Connecting Glowforge to Linksys EA9500


#1

Hello!

I am trying to connect my Glowforge to my Linksys Max‑Stream AC5400 Tri‑Band Wi‑Fi Router (EA9500) however it is having a problem communicating to it. I get the typical “stopped responding/encountered an error” message from my Glowforge and have had to set it up using my phone’s personal hotspot; which this tells me it’s a router issue and not the Glowforge.

It sees the router properly and allows me to enter the password, but after that is where it fails. I have my router set to WPA/WPA2 Mixed Personal which seems to work for every other device in my home. I have even tried connecting with all security turned to None and it would not connect either. I would like to say I wish there was a WPS access with Glowforge as it seems anytime I have an issue; that option usually works.


#2

Out of curiosity, does that router tell you what channel it picked for the 2.4GHz band?


#3

WPA is not supported (apparently that’s wrong - it is). WPA/WPA2 Mixed Personal is a mixed bag if I remember right - allowing both WPA (TKIP) and WPA2 (AES) - basically to support legacy devices.

I don’t know if that would be the problem (potentially) but unless you have a specific need for Mixed Personal, I would switch it to WPA2 Personal and give it a shot.

And sometimes it just seems like that page errors for some reason when in fact a connection gets established. Happened to me on my first set up (open network at the time).


#4

I wonder if it fails if the GF decides to update its firmware on first connection, which is likely as it will be some time since it was last online at the factory. Perhaps that causes a timeout


#5

I don’t know. But - this would coincide with prior reports of initial connectivity being difficult and subsequent (later) attempts to connect being no problem. I’ve done the set up a couple of times after the initial, and it went just like it was supposed to.


#6

It can, but currently it’s set up to change automatically as needed


#7

Sadly I need the Mixed personal due to older devices and also some finicky devices that doe not accept WPA2.

I heard about the page error being a “false positive” of sorts, but it seems it still did not connect to the wireless router anyways. I am going to use my Xfinity router to let it connect to that instead (even though I detest the thing) just so I can have something it can connect to without using my phone as the hotspot.


#8

Yes. I assumed that. I was hoping it told you what channel it picked. If you’ve got a Linux client somewhere, it’ll tell you what channel the router is broadcasting the SSID on. I’m curious because there is a conjecture that the Glowforge’s wifi stack may be constrained to the U.S. channels (up to 11 I think), if your router chose 12 or above that’d be interesting info.


#9

That might play out true - but the whole device error has been from the get go.


#10

typical for US is 6 for 2.4 and 11 for 5Ghz. I am in the US and those are default right now so didn’t want to mess with that. Seems it won’t even connect to the craptastic Xfinity router so will mess with those settings on that to adjust it from a Mix to straight up WPA2 given I don’t care about that router


#11

I’m curious mostly in cases where people have been able to connect through some routers but not others. Your idea about WPA is also a possibility, but support did list both WPA and WPA2 as supported in a recent response. They also listed WEP which I’m pretty sure did not work at some point so it looks like some of the fixes have gone into their configuration software.


#12

You’re right. I was thinking of a recent Dan post where he primarily listed WPA2 and “a few others.”

This must be the post you’re thinking of:

https://community.glowforge.com/t/new-router-glowforge-now-errors-out-on-connecting-to-wifi/21865/25?u=jbmanning5

If I remember correctly, on my initial set up, I was on an open network and dual-broadcasting 2.4/5ghz under the same SSID (Nighthawk router). Initially, the forge didn’t even see my network so I typed in the SSID manually. I received a device error but after that it recognized the network when it scanned for networks. I received a device error a couple more times when trying to connect to the now-recognized-via-scan network and then it was just magically connected and started calibrating (with no huzzah, you’re connected message).


#13

Yes, that’s the one. Though there are others earlier that say WPA2 only. So clearly evolving. Or jaz spoke too soon maybe.


#14

I’ve tried the straight up WPA2 settings and nothing. Next will be WEP and if that doesn’t work? Well I give up lol


#15

To update: I have tried WEP, Straight open, WPA, and WPA2… nothing

This is a very odd thing that Glowforge should have been aware about given the multiple problems that has been spoken on it. I will just send another email to them about it and see if I can get in touch; though I emailed them a few days ago and got nothing so who knows.


#16

Seems like you are moderately familiar with logging into your router interface? Might I suggest putting the phone into airplane mode, turn WiFi on, connect to the Glowforge WiFi and give credentials and have your laptop logged into the router to see if it shows up on the device/connected list?

Try to keep from making rapid changes to the entire set up. If it gives you a device error, just try it again and be somewhat patient.

I have a feeling (which isn’t much lol) that @palmercr may be correct about it trying to hit for firmware update and if it finds one, it disrupts the web setup process.


#17

I was tracking things earlier; the router showed no new device trying to access it. I even subdivided the router’s 2.4 and 5Ghz bands to see which one it could see or if one or the other was interfering (as this has happened before, but rarely). It seems Glowforge can only recognize the 2.4Ghz range which is sad considering how new of a device it is as well as how much money was spent on the development (and also tells me that the receiver and/or software for the wireless is a bit out of date)

If it is constantly trying to connect to see if there is a firmware update then something like this needs to be tweaked in the code to state “wait until connection process has been completed and connection is active”. I also personally feel there should be some software to this to allow you to force update the firmware or avoid it just in case of a bad code coming out; all things that are basic to even a regular printer to provide more user troubleshooting while avoiding the ability to give said user the power to modify any kind of code that may cause issues to the unit.

I hope Glowforge reads these forums as software ideas would be nice as I have started seeing other competitors now offer what Glowforge can do through their own software and more like offline access


#18

Yes. 2.4 only. Which is actually probably good; 5ghz, while less congested, is not nearly as good at penetrating walls, etc in a home and most people seem to be putting the Glowforge a bit away from their router.


#19

Which I understand, but when one has a lot running on the 2.4Ghz it can get too congested. So far I think I am alright, but we’ll see.

I’ve sent a message to Glowforge explaining in detail what is going on and once I hear from them I’ll update this post.


#20

Thanks for letting us know about this - I’m so sorry for the trouble. Last night, we applied an update to resolve the issue you were experiencing. I can see you’ve been able to connect and start printing since your last comment, which is great! Could you please let me know if you’re still having any problems?