Connectivity issues


I have Made a post before about not being able to connect to my wifi. i have changed routers, tried my phones hotspot and it hasnt worked. i even had my glowforge reset. the only thing that has worked was taking it to my brothers house and it connected right away. My question is, if i buy a 2.4ghz hotspot from verizon, will that work?

I don’t know if anyone can guarantee that would solve your problem. Have you tried setting up a dedicated 2.4GHz network for your Glowforge that none of your other devices can access? @pearl had a lot of problems with hers, and was able to solve it by using the 2.4 GHz “guest” wifi network for ONLY her GF, with everything else connecting to the main wifi account. We have horrid connectivity out here where we live, and that’s pretty much how mine is configured, too. Now I only have problems connecting when my kids visit and are all streaming stuff at the same time. :wink:


Perhaps a problems and support contact with Verizon could get a tech to your place to solve the problem?

1 Like

It sounds like you have local interference issues, so it’s unlikely a new hotspot would help.


Is it possible to get the same router your brother has since you know that works?

I’m so sorry to hear that you’ve been experiencing trouble with your Glowforge staying connected. As @eflyguy pointed out, the fact that moving your Glowforge to an alternate location and network allows it to properly work does indicate that your unit may be experiencing interference trouble while being connected.

I have some suggestions that may help to reduce the snag you’re hitting.

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

I hope this information helps! Please let me know if you see any improvement after working through these steps.

how do you set that up?

That’s going to be dependent on your router. Most of them nowadays have a way to provide a “guest” network so you don’t have to give people your main network password. It’ll be in your router documentation.

As @geek2nurse advised, the ability to setup a separate connection for a guest network is specifically related to the router you are utilizing, and can sometimes be restricted by your ISP. Contacting your ISP’s support department may help with obtaining instructions for doing so.

I hope this information helps. Let us know how it goes!


It’s been a while since we’ve heard from you, so I’m going to close this post.

If you are still having trouble, please start a new post or reach out at We’ll be happy to take a look.