Copy/paste from Illustrator 2020 has scaling issues between vector/image

Making a test print to engrave some lettering on 2-color acrylic.

Wanted to test difference between how it would look vector vs image.

Took three words, made copy, rasterized the second set. this is what i see in Illustrator before copy/paste.

Paste it into GFUI, and this is what i see.

The raster version shrinks.

Now, I know there are some “save as SVG” settings for making sure you’re not at responsive, but I didn’t think that applied in using the clipboard. and even then, it should affect the entire clipboard, not just the raster portion of the clipboard.

if i export to PDF and import, it works properly.



Great… something new for me to wonder about :thinking: :thinking: :thinking: :thinking:

i’ve never noticed this happening before, and i’ve copy/pasted with images in the past. so it could be new behavior.

I’ll try in CorelDRAW and PhotoPaint this evening and let you know how it goes.

Just tried on my version of AI2020. Typed some words, made a duplicate, rasterized the duplicate.
Selected both, hit copy.
Wouldn’t paste into GFUI at all.

Changed typed words from font to outline, tried again.
Worked fine, rasterized text was the same size as outlined text.

@ekla any thoughts?

It all has to do with the dpi settings used in your design program. It has to match the dpi settings that glowforge uses for it to be scaled the same.

this is true for sure with exporting, but i don’t know that it’s true on the clipboard.

Oddly, i just tried it and it worked properly with different test objects.


I wasn’t able to duplicate the issue with Corel.

I can’t replicate the error on the current AI CC and Chrome 83.0.4103.116.

Outlined text, duplicated 4 copies and rasterized those at 72, 150, 300 dpi. Copied all and pasted to GFUI with no issues or size discrepancies. Maybe something about the original artboard size? I’ve never had any sizing issues, exporting or copying, but I always start with a 12x20 template file for GF projects.

1 Like

I was not using a 20x12 art board
I rasterized at 300 dpi

Can’t think of anything else in AI that would cause the original error then. :woman_shrugging:

Perhaps just a random data transfer glitch, I have no idea what goes on under the hood of the paste to GFUI.

1 Like

i’m starting to think it was random. even though i could repeat it yesterday, today i’m not seeing it. same computer, no updates in illustrator.


It would have been interesting to see if they would have printed differently as well.

Thank you for letting us know about this and providing a detailed report. To you happen to remember the time of day you did your initial test pasting into the Glowforge App on the 6th? If possible, we’ll see if we can locate the logs and look into this further. Also, please let us know if you’ve been able to reproduce the behavior recently.

it was literally w/in a couple of mins (2:58 pm eastern) of when the initial post happened. because i copy/pasted the screen cap here right after i had pasted into the GFUI.

1 Like

Thank you for the additional information. I was able to locate logs from that time, and have shared them along with detailed notes with our team so we can look into this. If we need additional information or have next steps to try, I’ll follow up with you here.


Thank you for your patience while we looked into this further. It appears that there may be settings which differ between recent editions of Adobe Illustrator or ways in which artwork is copied that could be impact the scaling of artwork that is copied and then pasted into the Glowforge App. After further review, our team recommends saving SVG files locally and then uploading them to the app for the most consistent results.

We have a new guide on our support page which includes settings which other customer have reported working well. Here is a link to the guide: Quick: Saving SVG Design Files

Will you please let us know if the scale of your rasterized and vector text match when uploading an SVG which was saved using the settings in our guide?

1 Like

is this difference with bitmaps only? or with both vector and bitmap?

this was the only time i had this issue. and even with the same content later on i didn’t have the issue. just in that one short timeframe, when it happened to me twice (after that i switched to PDF for that file).

i’ve been copy/pasting without issue since. I’d hate to have to switch to exporting everything every time.

You don’t have to switch all your files over to an export method in order to continue printing; we only suggest it because it provides the most consistent results.

Without extensive testing between versions and settings in Adobe Illustrator, we can’t be certain what exactly triggered this issue to occur. The information from your example suggests that this is a difference in vectors and bitmaps. However, we’ve passed your report on so we can continue digging into it on this end. I’m sorry for the inconvenience and thank you for the details you provided.

1 Like