Designs are not showing on dashboard

Blank boxes not designs. Is someone aware of this at Glowforge?

Have you tried clearing your cache and or opening the app in a different browser?

Thank you for replying!
Haven’t had issues for the past 6 months of running prints from safari and just emptied cache still blank boxes

Are there credits given for premium subscription members when there are cloud based issues on Glowforge’s end that do not allow you to access your designs?

I wouldn’t know anything about credits. What happens when you try Chrome or Firefox? Are your design names still showing? What happens when you click the blank box?

Looks like they may be having issues today. I can’t upload any designs this afternoon. Times out and/or errors. Both Safari & Chrome. Not having issues with existing designs.

I don’t have those browsers on my computer. Clicking on blank boxes takes me to a blank page. No “rendering design.”

Thanks for sharing! Hopefully they get it resolved soon and I hope there are credits given to premium subscription members.

The Glowforge status page is not showing any problem.

Not sure what is wrong but I’ve had no problems with previous iterations of the design I’m trying to upload. Today its a no go. I can get a simple shape to upload but anything with complexity times out.
Maybe tomorrow…image

Hi @t.jeffsantos. I’m sorry to hear that you’re noticing blank boxes appearing in the Glowforge app Workspace when you try to load a design. If possible, could you send a screen shot of what you are seeing when you attempt to open a design.

If it’s an empty print bed image you’re seeing when it loads from the Dashboard, it may be due to the autosave feature occurring at point where any changes or deletions that overwrote the original design. If that is the case, there are some steps to try to correct this:

Could you please try the following steps for me?

  1. Open the design in the Workspace of the Glowforge app.

  2. Click the “…” button

  3. Click “Design Details”

  4. Click “Reset Design”

  5. The artwork for this design should load into the Workspace, and the following message should appear in the bottom right corner:image

Let us know if resetting the design was able to help, or send any screen shot to help us decide any next best steps. We’ll look forward to your response.


Thanks for getting back to me. Clearing out my cache has solved the problem however I know have to do it every session which is daily. Not sure what has changed but I’ve had to clear out my cache before which I believe was back in December so wasn’t surprised to have to do it again but this daily thing is a surprise.

Along with this when I do get a design to load when I hit print it will get stuck on uploading print but still engage the printer so that the light flashes and I can move forward with the session. But it will not show the countdown clock unless I refresh the page.

Again I’m not sure what has changed. I have not changed my OS on my Mac. Safari has not been recently updated. Any insight to why these issues are occurring would be appreciated!

Hi @t.jeffsantos. I appreciate you getting back to me with the added information. I’m happy to hear that the blank boxes issues loading instead of your design appears to be resolved, however a daily clearing of your browser’s cache should not be needed, and I’ll be happy to look into this further with troubleshooting.

I know you also mentioned that the countdown timer will not load unless you refresh the page in your browser after a print on your Glowforge has been engaged. To help me gather more information about any possible cause, can you do the following?

  1. Go to
  2. Look for the header that says “Your web browser’s unique URL”
  3. Click the button that says “Copy URL to Clipboard”
  4. Reply to this, and paste in the link provided

Also, I wanted to see if you were, or are, able to try another browser other than Safari. Since nothing has changed with the OS, or your version of Safari, I’d like to check to see if this occurs on other browsers as well.

I appreciate your time working with me to get this resolved and will look forward to your next reply.

Hi @t.jeffsantos. It’s been a while since my last response. I wanted to check in and see if you were able to complete the steps to help me troubleshoot the issue the your designs in the Glowforge app and Dashboard. If everything has been resolved, feel free to let me know as well, and I’ll look forward to hearing back. Thanks!

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email